iphone 3g silent switch not working

Discussion in 'Jailbreaks and iOS Hacks' started by surfklein, May 11, 2009.

  1. surfklein macrumors newbie

    Joined:
    May 11, 2009
    #1
    hey--
    just getting familiar with my unlocked iphone 3g. it is jailbroken and i have installed and run various apps to customize my sounds. i have noticed that when using my silent switch, the bell indicator that should appear on the screen does not appear and subsequently my phone rings when the switch is in the silent position (with the dot showing on the switch).
    has anyone found themself in a similar position? what is the fix? it is important for me to be able to enjoy the sounds i want on the phone but also use the silent switch.
    thanks for your attention.
     
  2. koollectablz macrumors 6502

    Joined:
    Feb 1, 2009
    #2
    Its busted, get a new replacement from Apple.
     
  3. surfklein thread starter macrumors newbie

    Joined:
    May 11, 2009
  4. pauliphone macrumors regular

    Joined:
    Nov 27, 2008
    Location:
    London, UK
    #4
    since jailbreaking i have had it a couple of times where the phone has been on silent but it has sounded for ring or text. It has only happened to me a couple of times though, majority of the time it is ok.
    Do you have notifier installed? If you do then you should get a silent bell in the top right of the screen when it is on silent, if that is not there then probably it is the switch that is bust.
     
  5. surfklein thread starter macrumors newbie

    Joined:
    May 11, 2009
    #5
    hey--thanks for the reply. not sure if i have "notifier" but the clock icon comes up when i set my alarm and the alarm feature works fine. does getting the clock icon indicate that i have "notifier" or is "notifier" specific to the silent bell icon? thanks again for your help.
     

Share This Page