Iphone 3g sound problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by NewYorkMafia, Oct 20, 2010.

  1. NewYorkMafia macrumors newbie

    Joined:
    Oct 20, 2010
    #1
    hi guyz

    i got a major problem with my iphone 3g sound and before you reply search on the forum ive searched the entire internet and none of the solutions work for me that y im askin

    the problem is that sometimes i dont get sound, no unlock/lock, application, message sound whatsoever. I cant even take a call :(. ive tried doing the following and this happens:

    1)play music from ipod and it just doesnt play. play button goes back to "play"

    2)start soniclighter app and it says phone or microphone being used and shut it off before using this app

    3) app "i am t-pain" doesnt start just goes back to the menu

    tried plugging in the headphones still dont play any sound!

    also sometimes when the sound is working the phone will auto hang and i have to restart and no sound again!!!!

    i bought my 3g second hand and when i got it none of these problems were there after i jailbroke it myself this stuff started happening!

    is it software or hardware??? any solution??? ive already tried evry solution on the internet :(!!
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Since it started AFTER the jailbreak, restore the phone and see if it works.
     
  3. NewYorkMafia thread starter macrumors newbie

    Joined:
    Oct 20, 2010
    #3
    tried restoring to different firmwares multiple times sometimes sound works sometimes it dont
    but all the time when it starts working, it stops working again after restart, etc

    sometimes when i leave the phone off for an hour or more and then start the phone it starts working again, but even with that trick it dont work all the time!

    any suggestions?
     
  4. NewYorkMafia thread starter macrumors newbie

    Joined:
    Oct 20, 2010
    #4
    ok i got it repaired and they replaced the ringer unit or sumthing and now its fixed!
     
  5. hob-nob-king macrumors newbie

    Joined:
    Dec 7, 2010
    #5
    where did you get it fixed!! i have exactly the same problem :( and how much did it cost you??
     

Share This Page