iPhone 3G Stuck in Recovery Loop :(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by WalkTheDino, Mar 15, 2011.

  1. WalkTheDino macrumors newbie

    Joined:
    Mar 15, 2011
    #1
    First of all, I'd like to say that this is my fault. (sadly)

    Here's the background info:

    I updated from 4.0 to 4.2.1
    I jailbroke and unlocked with redsn0w 0.9.6b6
    [​IMG]
    [​IMG]

    Uploaded with ImageShack.us
    (Picture will be relevant later)
    There was some sort of bug with my music player (it would make screeching noises frequently during playback)
    In an attempt to fix it, I restored through iTunes (notice, in the picture it states specifically NOT to do this? I completely forgot and did it... sigh) using a stock firmware.
    Hence the recovery loop (not fixed by standard methods)

    At this point, I'm confident that there's nothing that I can do to save it.

    If anyone is aware of a fix for this screw-up on my part, please tell me.

    Thanks in advance :D
     
  2. Leet Apple macrumors 6502a

    Leet Apple

    Joined:
    Nov 10, 2009
    Location:
    Canada
    #2
    Use RecBoot or Tinyumbrella to kick it out of Recovery
     
  3. WalkTheDino thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #3
    I've tried both, but I may be doing it wrong.

    To confirm:

    iTunes doesn't matter (if open or not), plug it in, put the iPhone on the recovery screen, press set auto-boot to true, and wait for reboot?
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    because your phone is on 4.2.1 and you use redsn0w to jailbreak, it is tethered. So, all you need to do is to hook it to your PC and tethered boot it up with redsn0w.

    Once it up and running, jailbreak it with Greenpois0n and you will have an untethered jailbreak.
     
  5. WalkTheDino, Mar 15, 2011
    Last edited: Mar 15, 2011

    WalkTheDino thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #5
    Trying, hope it works.

    Edit:

    Very concerned, redsn0w crashed mid-tethered boot.
    Waiting for it to stop rebooting...

    Edit2:

    Well, I waited for the pinapple to go away by itself and now I'm restoring through iTunes

    Any next steps? Or should I try redsn0w on a different computer or something?

    Edit3:

    redsn0w crashed again. i'm on win7 and I ran it in compatibility mode for XP SP2.
     
  6. Leet Apple macrumors 6502a

    Leet Apple

    Joined:
    Nov 10, 2009
    Location:
    Canada
    #6
    ACtually its the 3G iPhone so its untethered



    Try Downgrading to 3.1.3, because this had occurred to me and i simply downgraded an my iPhone was working flawless
     
  7. WalkTheDino thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #7
    Can you give me some help with that unless it's common sense?
    Usually downgrading takes a lot of technical steps which fail if done wrong (to my knowledge)

    To state/restate facts, I have 4.2.1 with the 6.15.00 bb and iTunes 10.2.1.1

    Anything else needed (aside from firmware)?
     
  8. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #8
    Once you have 3.1.3 firmware on you PC. also download tiny umbrella on your PC?

    1. Hook your iPhone to your PC.
    2. Open up iTunes.
    3. Shift + restore at the same time, it allows you to select firmware.
    4. Select 3.1.3 and iTunes will do the rest.
    5. Near the end, iTunes will give you a 1015 error.
    6. Open tiny umbrella and hit "kick device out of recovery mode".

    iPhone will boot up and you are done!
     
  9. WalkTheDino, Mar 15, 2011
    Last edited: Mar 16, 2011

    WalkTheDino thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #9
    Sounds like a plan. I'll try it tomorrow because I have a lot of school work to do for now. Thanks, I'll post if it works!

    Edit:

    Everything went supposedly well and I ended step 5 with a 1015 error. However, TinyUmbrella didn't work, nor did iReb. (It kicked it out of recovery mode and it went back in).

    [03/16/2011 16:23:17.838 Recovery Device disconnected: 011714002522566]
    [03/16/2011 16:23:25.413 Recovery Device connected: 011714002522566]

    So what should I do now?

    Edit2:

    Sooooooooo? :(
     
  10. kelsey.0119 macrumors newbie

    Joined:
    Apr 6, 2011
    #10
    Ugh!

    I am stuck in the same exact position with my iPhone. I have even taken it to someone for repair and he's had it for two weeks with no avail. But I do know that I read that Tiny Umbrella wont work for this specific situation... Anyone with ideas feel free to let me know!
     
  11. WalkTheDino thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #11
    What operating system do you use? I was doing stuff on a Win 7 computer and it wasn't working. But when I installed Windows XP on the same computer with a dual boot and did the same things, it worked.
    Also [Problem Resolved]
     

Share This Page