iPhone 3G touchscreen problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by muffiee, Jun 19, 2010.

  1. muffiee macrumors newbie

    Joined:
    Aug 27, 2009
    #1
    Hi guys,

    I have a problem, I bought a used iPhone 3G off ebay for £220 ($280?) which was stated in excellent working condition, however when I received it half of the touchscreen will not work.

    After contacting the seller he refused that there was a problem with it when he sent it out and that I was trying to scam him, any way long story short I couldn't get a refund and am now stuck with trying to fix this.

    I have scoured all over google and found it was most probably the digitiser, so I bought a new replacement screen+digitiser and followed the guide on replacing it.

    After replacing it still has the same problem, the bottom half of the touchscreen will not respond to touch yet the top half will, so this rules out the digitiser.

    I'm really not sure where to go from here, please can someone help me on fixing this problem as I'd hate to think I paid all that money for a brick.

    Any help you can give will be invaluable.

    Regards,
     
  2. Trash Can macrumors member

    Joined:
    Jun 19, 2010
    Location:
    Las Vegas, NV
    #2
    What was the seller's reputation? Maybe you're the one who got scammed? Not sure what you can do about the phone, but I'd leave him negative feedback since he wouldn't take it back and issue a refund.
     
  3. muffiee thread starter macrumors newbie

    Joined:
    Aug 27, 2009
    #3
    The seller had around 20 positive feedbacks and I did leave neg feedback for it since the product I bought wasn't received as described, I just wish I had of tested it before signing for it but never had a problem before, guess we live and learn.
    Other than being scammed I can only think it was in someway damaged while in transit to me.

    Would be grateful if someone has an idea how I can repair it as it's really strange half of the touchscreen will work but not the rest.
     
  4. muffiee thread starter macrumors newbie

    Joined:
    Aug 27, 2009
    #4
    Some pictures below if it helps, dosent lok damaged to me:

    [​IMG]

    [​IMG]

    With connector 3 attached:
    [​IMG]
     
  5. coldbeard macrumors newbie

    Joined:
    Jun 19, 2010
    #5
    I had a similar problem when I replaced the digitizer on my daughters iPhone. Turns out you have to be quite aggressive when plugging those connectors in. Got it working in the end.
     

Share This Page