Iphone 3g will not upgrade to OS4! Help please! :o(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sppepper, Jun 25, 2010.

  1. sppepper macrumors newbie

    Joined:
    Jun 25, 2010
    #1
    Hi all

    I have googled this and searched on the forums here but cannot find a similar problem. - Whic surprises me greatly! :eek:

    My iphone 3g (8gb) will firstly not fully synch with my itunes. It crashes when it gets to a part that says ' adding m4a file', to which it gives a number - presumably the name of the file. I am using the gorgeous Vista :eek: (which I dont think is the problem here - for a change).

    I have tried to just upgrade to OS4 without synching first - to which itunes warns me that i may lose some stuff. I press ok to continue and it seems to just crash because the loading bar doesnt even move!

    If anyone can explain why it is trying to add this m4a file and then crashes i would be most grateful. I think the m4a file is a ringtone i made a while back which has been working. But since this crash experience i deleted the file from both the iphone and itunes and it still tries to add it!!! :mad:

    Please help! :(
     
  2. iFerd macrumors 6502a

    Joined:
    Jul 20, 2007
    #2
    I'm not sure this applies to your situation, given your other troubles, but when I upgraded my 3G the progress bar moved about a tenth of the way and just stopped. After a long, long time it did finally begin to move again. I thought my installation had hung, but something actually was going on after all.

    If this is a help to you, it means having more patience than seems reasonable.
     
  3. sppepper thread starter macrumors newbie

    Joined:
    Jun 25, 2010
    #3
    Thanks. Mine did do what you say yours did by only going a tenth of the way. I will plug it in and try again tonight and try to have patience. I will return here if no joy though. Thanks again. :)
     
  4. sppepper thread starter macrumors newbie

    Joined:
    Jun 25, 2010
    #4
    Still no joy unfortunately. Does anyone have any other ideas? I don't know if I can even back up my contacts to my pc before I do a restore (if it comes to this)???

    This is highly frustrating and very time consuming. I left it to update over night and still didn't work.

    I've tried synchronising again for hours and it still gets stuck when trying to 'add and m4a file'.

    Please help.
     

Share This Page