iPhone 3G with WiFi issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Manek43509, Aug 21, 2010.

  1. Manek43509 macrumors newbie

    Joined:
    Aug 21, 2010
    Location:
    Norwich, UK
    #1
    Hello, all... First post here! :)

    Basically, I have a 3G iPhone, and recently, I've been having problems connecting it to a wireless network...

    These problems started about two weeks ago, at the most - prior to that time, it was fine...

    It started by not detecting any networks - I would go into the WiFi part of "Settings", and the little wheel would go 'round and 'round for ever, always saying it was looking for networks, but never finding any... Even when I knew there was a network within range - at home, for example - it could not find it... It just had the wheel, constantly...

    Then, phase two - I can't even get into the WiFi settings any more... My "Settings" screen looks like this -

    [​IMG]

    As you can see, the WiFi part is now grey - it's as if it's been disabled completely... No longer is it just that the iPhone can't find a network - WiFi isn't even an option any more!

    So, I have tried the "soft reset" - that didn't work...

    I have tried "restoring" the iPhone, using the button for same inside iTunes - that didn't work either...

    I have read elsewhere that you can fix it by baking the iPhone in an oven - no way!!

    Are there any other options?? Please help...!
     
  2. MAJE5T1C macrumors newbie

    Joined:
    Nov 13, 2009
    #2
    Hi your iphone's been bricked by jailbreak/unlock there is nothing that can be done

    If it still under warranty exchange it in a apple store for free there and then no questons asked
     
  3. Manek43509 thread starter macrumors newbie

    Joined:
    Aug 21, 2010
    Location:
    Norwich, UK
    #3
    Thanks, MAJE5T1C - I haven't done any jailbreaking at all on the iPhone... Are you suggesting that that might fix it, or that that's what's caused the issue?
     
  4. asuman2012 macrumors newbie

    Joined:
    Sep 21, 2010
    #4
    my iphone 3G is doing a similar problem, it will not detect any wireless signals when i know there are some in the area i am. My Wi-Fi button in settings is still accessible, but the wheel just goes around and around like its searching and not funding anythong. i dont have jailbreak or anything else like that, so what could be causing it.
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    Your wifi chip on the logic board has gone bad. It happens. You could try a restore in dfu mode to make sure it's not software-related. Setup as new.
     
  6. asuman2012 macrumors newbie

    Joined:
    Sep 21, 2010
    #6
    thank you aggie, but i did a restore to factory default, and did the set up as new and it still didnt work. so then its the chip? is there anything i can do for that short of getting a new one?
     

Share This Page