iPhone 3g won't restore

Discussion in 'iPhone Tips, Help and Troubleshooting' started by powvang, Apr 19, 2011.

  1. powvang macrumors newbie

    Joined:
    Apr 19, 2011
    #1
    I just recently bought an iPhone 3g 3.12. It was jailbroken and unlocked when I bought it. So I tried to update it to the newest firmware. While it was almost updating, my little brother unplugged the USB from my iPhone. Now it is stuck in recovery mode. I tried to recover it through iTunes, but it says error (1015). I've tried to use iREB, Tiny Umbrella, and Recboot, but they all don't work for my iPhone. I'm not sure exactly what I need to do to fix it. Do you guys have any ideas of how to fix it?

    Much appreciated to you all.
     
  2. Trranceman macrumors newbie

    Joined:
    Apr 6, 2011
    #2
    i had such error and nothing helped, then i tried to make custom firmware with snowbreeze in expert mode, when cooking was done snowbreeze asked me to put in dfu, i put phone in dfu, then i restored it via itunes pointing custom firmware, it should help, i dont know how it will work on old ios but it worked for 4.2.1
     

Share This Page