iPhone 3G won't rotate to landscape

Discussion in 'iPhone Tips, Help and Troubleshooting' started by carma92, Jul 30, 2010.

  1. carma92 macrumors newbie

    Joined:
    Jul 30, 2010
    #1
    I go to labyrinth and all four directions work and in games where i have to shake the phone it works. when i go to safari or ipod it only stays vertical. I have checked all my apps to see if something is telling it to not tilt but notta. btw : youtube and things that default to landscape are landscape but no tilting screen. its pissing me off. any help would be appreciated.
     
  2. carma92 thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #2
    as a side note i put a movie on there and it seemed to default to landscape on its own but podcasts in ipod still cannot rotate they stay narrow and the controls stay on the screen.
     
  3. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #3
    I'd be happy if it were me. Landscape is so annoying.

    Do you have a 3G, 3GS, 4? Also what OS
     
  4. carma92 thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #4
    only for web pages is it bothering me and the fact that i hate that something is broken software/or hardware.
     
  5. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
  6. carma92 thread starter macrumors newbie

    Joined:
    Jul 30, 2010
  7. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
  8. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #8
    I think when you jailbreak you revoke the right to be bothered by problems with your iPhone that aren't hardware haha. My phone sucks now from jailbreaking/restoring it like 5 times and never doing a full restore and setting it up as a new phone.

    I'm pretty sure it's probably either something turned on in some jailbreak app or some kind of software glitch.
     
  9. carma92 thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #9
    yes i have sbsettings and i checked the rotation feature on and off if i am using it right.
     
  10. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #10
    look in cydia and see what you have installed like maybe rotation inhibitor or something?
     
  11. carma92 thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #11
    rotation inhibitor is installed and i have tried changing its setting and uninstalling it and doing a reboot but nothing changed.
     
  12. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #12
    did you look in the settings for sbsettings I think it's in the mobile substrate add ons section and see if that rotation was set to on?
     
  13. carma92 thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #13
    where is this mobile substrate you speak of? not familiar with that
     
  14. carma92 thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #14
    found it but i turned the rotation inhibitor off in the substrate. i rebooted now the rotation is gone from the drop down menu in sbsettings but still no tilt.
     
  15. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #15
    ah idk... how long ago did it start and what did you install around that time
     
  16. carma92 thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #16
    it happened one night all of a sudden and i have no idea if there was anything new that caused it.
     
  17. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #17
    my only other idea would be to start uninstalling stuff in the order you think you installed it around then until it changes
     

Share This Page