iPhone iPhone 3GS 16GB week 22 JB max?

Discussion in 'Jailbreaks and iOS Hacks' started by Immanueldk, Apr 5, 2013.

  1. Immanueldk, Apr 5, 2013
    Last edited: Apr 5, 2013

    Immanueldk macrumors member

    Joined:
    Oct 23, 2007
    #1
    Hello,
    I have a iPhone 3G 16GB Model A1241,
    and wonder which firmware I can update to then JB.

    I just updated from 3.1.3 to 4.2
    which jb tool would you recommand? redsn0w?

    thank you so much!
     
  2. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #2
    well 2 opions here. downgrade to ios 4.1, or download the ios 6.0 ipsw and select that. i would downgrade to 4.1, save the blobs, and then update to 6.1.3, and jailbreak.
     
  3. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #3
    I was aware the old bootrom 3GS doesn't require any shsh blobs. However, the newer bootrom 3GS requires shsh blobs to restore to an unsigned firmware.

    Your iOS 6.x shsh blobs may be invalid since you did not manually save them. You should still have iOS 5.1.1 shsh blobs that you can restore to. Download the latest version of iFaith and check the shsh blobs cydia has for you

    ----------

    I wouldn't recommend a 6.1.3 tethered jailbreak. If he has 5.1.1 shsh blobs, that would be better
     
  4. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #4
    If you phone has the oldbootrom you can untether jailbreak on 6.1.3
    Otherwise it will be a tether jailbreak on 6.1.3

    If you have blobs for 6.1.2 you can restore to that an untether jailbreak.

    Is your phone currently jailbroken, if yes, Cydia might have 6.1.2 SHSH/blobs but you need to verify with iFaith if they are complete.

    If not jailbroken before and don't have SHSH's save manually you can't restore to 6.1.2
     
  5. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #5
    Incorrect. Old bootrom only means untether JB. SHSH is another thing.
     
  6. viperGTS macrumors 65816

    Joined:
    Nov 15, 2010
    #6
    You have an iPhone 3G. 4.2 was the latest for it.
     
  7. rygamble macrumors regular

    Joined:
    Feb 1, 2012
    #7
    It says 3GS.
     
  8. TheRainKing macrumors 6502a

    TheRainKing

    Joined:
    Jun 11, 2012
    #8
    This.

    Old bootrom 3GS cannot downgrade to unsigned firmware without SHSH blobs. If it could then I would have downgraded my 3GS back to iOS 5. :mad:
     
  9. viperGTS macrumors 65816

    Joined:
    Nov 15, 2010
    #9
    Okay, well then save your SHSH for 3.1.3, then restore to the latest version that iTunes allows, then try again.
     
  10. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #10
    Oh, thanks for the correction

    ----------

    I never tried the downgrade as it was problematic. I would love to downgrade my old bootrom iTouch 2G to 3.1.2 but only learned about shsh blobs when 4.0 came out :(
     
  11. Immanueldk thread starter macrumors member

    Joined:
    Oct 23, 2007
    #11
    updated to 4.2 from 3.1.3

    Like i wrote in the beginning when I asked the iPhone 3GS earlie 2009 was with 3.1.3 iTunes said there is a new version for the device 4.2!

    I have updated the device to 4.2, but now it need an activation through a simcard without pincode.

    So, what can I do to update it further to 6.1.2 where Evasion JB works perfectly?

    kind regards.


    OH I SEE ITS A IPHONE 3G??? HOW CAN I SEE THE DIFFERENCE BETWEEN IPHONE 3G AND 3GS???
     
  12. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #12
    Look at the model number at the back of your phone: http://support.apple.com/kb/ht3939

    You probably need to make a custom firmware with hacktivation included. You might need to put your device into pwned DFU mode too

    sn0wbreeze might work for you
     

Share This Page