iPhone 3GS 3.1.2 Stuck Apple Boot Loop

Discussion in 'Jailbreaks and iOS Hacks' started by superkershaw, Feb 17, 2010.

  1. superkershaw macrumors newbie

    Dec 26, 2009
    I have searched everywhere and tried everything I can think of, so I apologize for creating my own dedicated thread but I have no idea what else to do.

    iPhone 3GS 32G, old bootrom (untethered), 3.1.2 unlocked/jb with blackra1n/blacksn0w.

    Mac OS X 10.6, iTunes 9.0.3


    Everything worked perfectly except push notifications and after booting up, I would need to reset the network to get wifi working again.

    This morning, I was trying to fix my push notifications and tried various things and decided to go ahead and pay for the pushfix. (pushfix.info)

    In preparation, I decided to uninstall an old pushfix I had from the fishbone.ge repository.

    I uninstalled, rebooted and was back into my phone (after an oddly lengthy reboot). I went to my network settings and noticed wifi wasn't working, so I reset the network settings and rebooted. Since then, my phone has been stuck in the apple logo and unable to boot. It simply cycles to a black screen then back to the apple shortly after.

    Unfortunately I don't have my SHSH ECID backed up as I had avoided 3.1.3 completely knowing the issues/complications, and didn't do the research one would do to know you need to back this up.

    Phone boots into DFU and is recognized by itunes as in DFU in both mac and windows

    This is what I tried (on both mac and windows computers):

    • Restoring to the original 3.1.2, obviously not working.
    • Restoring to pwnagetool 3.1.2, not working (error 1600)
    • Restoring to pwnagetool 3.1.3, not working (error 1600)
    • Built CFW with both pwnage tool 3.1.4 and 3.1.5
    • iRecovery (can't find phone, or can't claim USB on windows)
    • booting without SIM card, not working
    • redj0hnny not finding phone
    •*iREB recovery loop fix, not working (does nothing)

    SO the only solution I can think of is to simply straight upgrade to 3.1.3, but obviously I dont' want to do this because it will upgrade my baseband and my bootrom (will it?)

    I know downgrading is one thing, but is it really still not possible to upgrade to the same firmware that my phone has in the first place?

    if anyone has ANY clue how to get out of this stuck apple loop or how to deal with this itunes 1600 error, I would appreciate it so so much.

    Thanks a lot
  2. thelatinist macrumors 603


    Aug 15, 2009
    Connecticut, USA
    Can you get the phone into recovery mode (with the USB & iTunes logo)? If you can, then you should be able to restore to a custom 3.1.2 (or 3.1.3) firmware. If all you can get into is DFU mode, there is nothing you can do but restore to 3.1.3 official.
  3. germanium macrumors newbie

    Feb 17, 2010
    the exact same thing happened to me, I have an iphone 3gs with a jailbroken 3.1.2 firmware. My wifi was not working properly so I thought about resetting the network to fix it, but after that the wifi was greyed out, so I tried restarting the network again only this time it entered in a reset loop, so I had to do a restore. Fortunately I had the SHSH backup on cydia (thank you saurik!) and had no problem doing the restore.
    Unfortunately for you I think you are out of luck until a jailbreak is out for the 3.1.3 firmware. You cannot install now anything below 3.1.3 since apple stopped signing it after they release the new one.
  4. ingoman macrumors newbie

    Feb 18, 2010
    same here!

    OMG: sounds like others have the same issue than I have. same thing happend to me yesterday. except that I was doing nothing with resetting or the like. I was calling and the call was canceled. I lost the provider net and to force the search I was switching on/off the plane mode.
    the phone freezed and nothing except power and home button brought it to do something. well and since then, my phone is in the loop with the sweet apple... I can recover the DFU mode but without itunes and cable sign. so itunes recognizes the phone in that mode. how can I bring itunes to use a restore from 3.1.2 without downloading the 3.1.3?
    I cannot believe that I am stuck here! and I don't believe that geohot and co are getting any new versions of their wondertool... are they working on it?

    I did not try anything because I have not read anything good about my situation!

    so help is highly appreciated.
  5. thelatinist macrumors 603


    Aug 15, 2009
    Connecticut, USA
    If you have the old bootrom and can get into recovery mode, then you can restore to a custom 3.1.2 firmware. If you have your SHSH on file, you can restore to a stock 3.1.2 firmware. If neither of these is true, you are probably out of luck.

    And I doubt very much either Geohot or the Dev Team is going to release a 3.1.3 jailbreak. I'm pretty sure the Dev Team is still working on porting PwnageTool to Win/Lin, and Geohot is trying to break SHA using hacked PS3s.
  6. ingoman macrumors newbie

    Feb 18, 2010
    Other approach if you are o2 uk

    the thing is, that I don't know if I have stored the shsh thing.
    meanwhile I found a very good solution for my situation. my iphone is a pay&go from o2 uk and the offer a unlock for iphones (15 pounds). simply fill out a form on their website and wait.
    I guess I will try this after I have got the 3.1.3 to work again.
    the other stuff will just end up in the same situation again some time...
    and a factory unlocked iphone will increase the price as well if 4G is released....
  7. ingoman macrumors newbie

    Feb 18, 2010
    iphone works again

    no need for any official unlock :)
    I fixed my phone again. loaded the org file 3.1.2 using itunes and shift key... maybe its just because I have saved the shsh... I am happy again!
    issue for my phone was reproduceable. DO NOT SWITCH PLANE MODE ON/OFF very quickly... I personaly will not touch this key anymore! ever!

    PS: if you have any questions about what I did... you can reach me through caringo.at

Share This Page