iPhone 3GS 3.1.2 unresponsive touch screen. Anyone else have this?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by klamse25, Oct 25, 2009.

  1. klamse25 macrumors 6502a

    klamse25

    Joined:
    Oct 25, 2009
    #1
    I have a brand new iPhone I just bought yesterday.
    It works fine but after using it for around a couple minutes, the touch screen doesn't respond until I lock the phone, and unlock it.
    This gets very annoying, because when I'm playing games, I have to "revive" the touch screen by locking, then unlocking.
    Anyone else have this?
    Are there any solutions anyone has found?

    Thanks:)
     
  2. neilp4453 macrumors regular

    Joined:
    Oct 16, 2007
    #2
    Hmm...haven't experienced that on any of the iPhones I've used so far.

    I assume you have tried all the conventional fixes (mostly restarting the phone).
     
  3. klamse25 thread starter macrumors 6502a

    klamse25

    Joined:
    Oct 25, 2009
  4. Blueline29 macrumors 68020

    Blueline29

    Joined:
    Jun 16, 2009
    Location:
    Windermere, FL
    #4
    I haven't experienced that at all since updating, thank goodness. Sorry to hear it's happening to you!
     
  5. firewood macrumors 604

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #5
    I have an iPod Touch 2G which does this, no response to touches. Even several OS updates haven't fixed this problem, so it's probably a hardware fault. After turning the display off using the lock button and rubbing the screen with the cleaning cloth, touches start working again.

    I thought about taking it in for an exchange, but it always works perfectly on days when I have time to head over to the Apple store. If you can get it to fail consistently, take it back for a working unit.
     
  6. wic macrumors newbie

    Joined:
    Oct 26, 2009
    #6
    Yes, I have the exact same problem with my new 3GS 3.1.2. The touch screen becomes unresponsive and the only way is to lock the phone (top-right button) and then unlock it by sliding the bar. Another way is to shake the phone!

    This happens several times per day. If I were to use it constantly, I'm sure it would occur several times per hour. :mad:

    There does not seem to be any pattern to it, and it is not easily reproducible. I have tried restoring the iphone completely, but it still occurs. I have seen it happen in these locations:

    • While using the keyboard (message)
    • While playing games
    • In the home menu. Cannot select apps or slide app page.
    • After a phone call. Cannot press 'Hang up' or any of the other buttons

    There are reports about this all over the place. One guy even posted a video of it: http://www.youtube.com/watch?v=OXOYpsdnEeM
     
  7. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #7
    Mine did it with 3.0 while in Flight Mode, I was using it in iPod mode. Got to the point where it would only accept one "button press" then needed to be locked and unlocked then would accept another "button press".

    A reboot cured it, and it's not done it since.
     
  8. pakster macrumors newbie

    Joined:
    Apr 17, 2009
    #8
    Im having the same problems. With both 3.1.1 and 3.1.2
     
  9. Digidesign macrumors 6502

    Joined:
    Jan 7, 2002
    #9
    Glad to see I'm not the only one having this problem. It happens also when locking after watching a video in iTunes.


    My phone is:
    -Version 3.1.2 (7D11)
    -Carrier AT&T 5.6
    -Model MB717LL
    -Modem Firmware 05.11.07
     

Share This Page