IPhone 3GS 3.1.3 jailbroken want to update to 4.0

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Ginoq, Dec 27, 2010.

  1. Ginoq macrumors newbie

    Joined:
    Dec 27, 2010
    #1
    Hi. Any help appreciated.

    I have a 3GS jailbroken and unlocked on 3.1.3, on a non-AT&T carrier with no blobs saved as far as I know (friend jailbroke it on a different computer) I'd like to upgrade to 4.0 to maintain my unlock and fix some wifi issues. How can I do this? It may help to mention that i currently do not have a valid AT&T sim and AT&T is unavailable where i live. I can possibly gain access to a non active AT&T sim at a later date though. I understand that even if I could find a 4.0 firmware file I'd still have to trick iTunes into thinking that 4.0 is the latest fw. And once i get the phone on stock 4.0 that I'll need an AT&T sim to activate. I know there is probably a way of doing this, but I only have one shot at this and don't want to screw this up. Thanks for any help.
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    You can only go to 4.0 if you have the SHSH blobs saved. Look in Cydia, top of screen, and see if by some chance you do have any blobs saved. At the top would say "SHSH: iOS...."
     
  3. Ginoq thread starter macrumors newbie

    Joined:
    Dec 27, 2010
    #3
    Thanks

    It says i have shsh for 4.0 4.01 4.02 and 4.1. But I'm on 3.13. Does that mean it's saved with cydia? Is there another way to tell?
     
  4. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #4
    Yes, that means the SHSH are saved for those firmwares. To upgrade you have to edit your host files.
     
  5. Ginoq thread starter macrumors newbie

    Joined:
    Dec 27, 2010
    #5
    Thanks for your reply, and please pardon my ignorance, but I don't know how to do that. Do I have to use a third party program? I'm using windows xp btw.

    From what I can gather, the shsh is saved with cydia so this should be a pretty easy fix. I'm just missing an important step. Possibly the editing you're telling me to do. With this method am i going to have any problems with activation? Is my lack of an AT&T sim going to cause grief? Again I apologize for my ignorance, and thank you in advance for your help.
     
  6. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #6
    If you upgrade to 4.0 or 4.0.1 you need an AT&T sim to activate your iPhone. The jailbreak requires the iPhone to be activated, then you jailbreak straight from the iPhone <www.jailbreakme.com>

    If you upgraded to 4.0.2 then you can you LimeRa1n (will hactivate the iPhone) to jailbreak.

    Don't go to 4.1 unless you have a custom firmware to preserve your baseband. 4.1's baseband isn't unlockable.

    To edit your host files: http://www.iclarified.com/entry/index.php?enid=7557
     
  7. Ginoq thread starter macrumors newbie

    Joined:
    Dec 27, 2010
    #7
    Ok. Cool. Now the only thing I'm not clear on is do I need an active AT&T simcard. As in does the simcard have to be a currently under service contracted sim? Or can I use my old AT&T sim?
     
  8. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #8
    You can use the old sim card to activate. As long as it's an AT&T one.
     
  9. Ginoq thread starter macrumors newbie

    Joined:
    Dec 27, 2010
    #9
    Awesome. You've been a huge help. I'll post back when it's done.
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    PsstGreek is great:D
     
  11. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #11
    No problem.
     
  12. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #12
    Thanks bud.
     

Share This Page