Iphone 3GS 3.1.3 won't upgrade

Discussion in 'Jailbreaks and iOS Hacks' started by cschmelz, Dec 18, 2011.

  1. cschmelz macrumors 6502

    Joined:
    Jun 6, 2007
    #1
    I have an iPhone 3.1.3 (baseband 5.12) that I CANNOT upgrade beyond 3.1.3 at all. I get error 1604 most commonly, I've done everything I can think of (new USB port, new USB cable, new login identity, Windows 7 machine, different Mac) and all give the same error.

    I jail broke it after all that and it took the jailbreak just fine, but now what! I want to get at least 4.1 on it, if not 5.0.1--official is fine, don't care about the jailbreak, I just want it to take the upgrade!!

    HELP!
     
  2. JunkyDog macrumors 6502

    Joined:
    Sep 17, 2011
    #2
    Check your host file and check TU if you have set it to Cydia server, uncheck that in advanced options in TU, then try again...
     
  3. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #3
    if you haven't been saving shsh blobs then you can only upgrade to signed firmware which is 5.0.1 and for some reason 4.1 those you can upgrade too without blobs. be sure to preserve you baseband though.
     
  4. cschmelz thread starter macrumors 6502

    Joined:
    Jun 6, 2007
    #4
    I'll give up the baseband...I honestly don't care. I have an iPhone 4 as a backup phone and my primary phone is a 5.0.1 stock 4S. I just want to upgrade the OS so the kids can use the 3GS as a game machine. Most games won't install to 3.x.x anymore and require 4.0 or greater!

    I know my host file is fine as I upgraded the 4 to 5.0 via iTunes when it came out w/o troubles...

    Ugh.
     

Share This Page