iPhone 3G's 3G not working?

TheSalv

macrumors newbie
Original poster
Sep 3, 2011
9
0
I was unsure where to put this topic as my iPhone is jailbroken, so i guess i'd start here, but my iPhone's 3g isn't working, everything is working except that, i can use WI-FI with no problems whatsoever. I apoligise for little information, i don't know what else to write, but it's a problem that's been bugging me for quite a while. Anyone have any suggestions?

I'm running 3.1.2 FW and jailbroken with Redsn0w and unlocked with Ultrasn0w.
 

TheSalv

macrumors newbie
Original poster
Sep 3, 2011
9
0
You're sure enable 3G is on in settings right?
You tried a reset network?
Are you positive your carrier has 3G available in your area and it supports the iPhone bands?
I'm sure. Me and my brother are both on the same tariff with the same carrier and his 3G works fine. However he has an iPhone 4, not that it should make a difference, but yeah. Everything's turned on. When i jailbreaked my iPhone the first time, 3G worked, but after the 2nd time, it doesn't.
 

TheSalv

macrumors newbie
Original poster
Sep 3, 2011
9
0
Weird.
So you just get Edge?
Does your sim pull 3G when inserted in other phones?
Wonder if it's a hardware issue with your 3GS.
The only thing i get is WI-FI, i don't get 3G or GPS. And my 3G works perfectly when used in my old Samsung phone, i haven't tried it in my brothers iPhone as of yet.

----------

Nevermind, i fixed it. Thank you for your help anyway :D if anyone else is having problems and is on Tesco mobile, go here
http://nealbo.hubpages.com/hub/Tesco-Mobile-iPhone-Could-not-activate-cellular-data-network-error
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,404
At the iPhone hacks section.

TheSalv

macrumors newbie
Original poster
Sep 3, 2011
9
0
Your link is not working.
So what was the problem and what fixed it?
Basically, O2 and Tesco are joint carrier's so to speak. And when i first unlocked my iPhone i had to use an O2 simcard to unlock it. When i did that, it entered all the details in the cellular data to O2's settings, then when i used ultrasn0w so I could change to my Tesco sim, it didn't change, so i had to go on the Cellular data and change the details to match Tesco's.

Here's instructions for anyone that needs them from the website.

The manual solution

You will need to (on your iPhone):

Go to settings
General
Network
Cellular Data Network

Check that your settings are as below:

APN: prepay.tesco-mobile.com
Username: tescowap
Password: password

(The above is for the Cellular data, Visual voicmail and MMS sections of your iPhone settings)

The rest of the settings are identical to O2's so can be left.

The automatic solution - use if your settings look correct or the above doesn't work for you

Visit the unlockit.co.nz page on your iPhone (when connected to wifi)
Select contine and then Custom APN
Press the Carrier drop down menu and scroll down to UK - TESCO and then press Done
Press Create Profile
Press Install and yes to the questions.

----------

Your link is not working.
So what was the problem and what fixed it?

Edit, here's the correct link.
http://nealbo.hubpages.com/hub/Tesco-Mobile-iPhone-Could-not-activate-cellular-data-network-error
And it needed your data network APN settings for your carrier.
That's a given, they dont automaticly get entered there. You gotta make sure they are the correct ones for your carrier data to work properly.
Thanks for correcting :) and i'm kinda new to the whole jailbreaking kinda thing, so i apoligise for the dumb question :p but thanks for your help :)