iPhone 3GS 4.0 to 4.0.1 (No SHSH) (Jailbreakme crashing safari)

Discussion in 'Jailbreaks and iOS Hacks' started by SeanZy, Aug 16, 2010.

  1. SeanZy macrumors 6502a

    Joined:
    Dec 29, 2008
    #1
    Okay I am running 4.0 on my 3GS, and jailbreakme.com keeps crashing my safari and it looks like the only option is to upgrade to 4.0.1 but the new firmware is out now.

    I do not have any SHSH blobs or any of that stuff, so my question is what is the easiest and quickest way to get updated in my situation.

    Trust me, I have searched, and all I could find was talk about blobs and everything. Someone please just lay it out real quickly.
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    Use tinyumbrella and see if you can still save SHSH 4.0.1. If yes, it means Apple is still signing = can restore to it through iTunes. If no, means your only course of action is to restore to 4.0.2.
     
  3. SeanZy thread starter macrumors 6502a

    Joined:
    Dec 29, 2008
    #3
    Oh shoot I meant to say that jailbreakme keeps crashing my safari.

    I want to jailbreak this phone :x
     
  4. SeanZy thread starter macrumors 6502a

    Joined:
    Dec 29, 2008
    #4
    this is what I got from umbrella:

    08/16/2010 12:14:35.283 SHSH SUCCESSFULLY saved! [Click Here to Open] 08/16/2010 12:14:35.319 You have saved your SHSH locally and the request was sent to CYDIA. This means that CYDIA DOES have your SHSH. Do NOT bug semaphore about the Cydia home page showing this version. 08/16/2010 12:14:35.337 Caching shsh files... 08/16/2010 12:14:35.406 Found [1] shsh files to cache... 08/16/2010 12:14:35.440 Cached [1] shsh files 08/16/2010 12:14:55.272 3582708332022-iphone-4.0.1.shsh has been opened in Finder

    So what should I do from here to get to 4.0.1 ? Should I just use the ispw file (since it seems to be signed still), or use umbrella, and how do I do that?
     
  5. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #5
    Use restore through ITunes with 4.0.1. If it gives you error about device not eligible, enable server option in tinyumbrella and try again in iTunes.
     
  6. kknet macrumors newbie

    Joined:
    Jun 18, 2007
    #6
    Sorry 'bout hijacking the thread, but I'm in the same situation.

    To my question; how exactly to you restore to 4.0.1? Do you need to manually download the ispw file from somewhere?
    Thanks!
     
  7. terraphantm macrumors 68040

    Joined:
    Jun 27, 2009
    Location:
    Pennsylvania
    #7
    Yes. Then click shift + restore (or option + restore if you're on a mac), which will then open a file browser so that you can point to the ipsw you want.
     

Share This Page