iPhone 3GS 4.2.1 help please!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by michaelv1143, Jul 19, 2011.

  1. michaelv1143 macrumors member

    michaelv1143

    Joined:
    Jul 19, 2011
    #1
    I have a iPhone 3GS that I unlocked and had jailbroken at the beginning of this year. It took me forever to figure out but I had to end up using the iPad baseband when I finally did get it unlocked and jailbroken. It worked perfectly! and just the other day i downloaded an app through Cydia, which i rarely do, and it froze so i decided to just restart my phone...It was stuck on the apple logo for the longest. So i plugged it into the computer thinking I'd be able to do a restore which is when the phone went into the itunes/usb plug on the screen and has been stuck since... I tried doing a restore with custom firmware but the "This iPhone is not eligible for the requested build" keeps coming up. So i figured I would try creating a custom firmware in redsn0w and I downloaded custom firmware and the official apple firmware and when I click the official firmware in redsn0w it keeps says "Unable to recognize specified IPSW" and the IPSW was downloaded properly and not showing up as a .ZIP or anything like that..
    I've googled for the past day and cant seem to find any solutions...and i do not have the shsh saved...I dont know what that is lol but i know i dont have it... I just dont really know where to start to try and fix this problem...so ANY help at all would be MUCH appreciated! Thank you!
     
  2. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #2
    If you're trying to restore to 4.3.3, it won't work because Apple is no longer signing it and you don't have SHSH.

    But, you should have SHSH for the firmware you were jailbroken/unlocked on. What firmware was that? You should be able to create a custom firmware with Sn0wbreeze or Pwnagetool for that firmware and then restore to it with iTunes and pwned DFU mode.
     
  3. michaelv1143 thread starter macrumors member

    michaelv1143

    Joined:
    Jul 19, 2011
    #3
    hi! thanks for the response! uhmm...well i tried restoring to 4.2.1 but it doesnt even attempt to restore it, it just "extracts" and then gives me the error. But I was on 4.2.1 firmware... I'm not really sure where i would find the shsh even if i had it?

    i think i tried to create a custom firmware using pwnagetool but every time i click on the Official apple firmware 4.2.1 it says that the firmware bundle isnt correct or something like that...
     

Share This Page