iPhone 3GS battery problem.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by tyte07, Sep 30, 2009.

  1. tyte07 macrumors newbie

    Joined:
    Sep 30, 2009
    #1
    I've been using my 3GS for a few weeks now without any problems until yesterday morning. I woke and took out the phone from the charger after I left it on there at night and felt that it was a little bit warm, but I didn't really think about it. Then 3 hours later, I looked at the battery and it said 58% on there. All I did within those 3 hours was listen to music for 20 minutes, with no phone calls at all. Then, 3 hours later, my phone ran out of battery. I come home at night and charged it, but it became really warm. I took it out of the charger and the % was going down really really fast. Now, the phone is always really warm, even more so when I plug it into the charger. Battery is still going down like crazy.

    It's jailbroken and is running 3.0. I've never upgraded it to 3.1 before. What should I do now? Restore it or something?
     
  2. tyte07 thread starter macrumors newbie

    Joined:
    Sep 30, 2009
    #2
    I've just read and found out that I can't restore my 3GS to 3.0 without losing jailbreak. What should I do now? Although the iPhone isn't warm anymore, I'm still losing 10% in like 40 minutes without even touching it or doing anything. What's making me mad is that it was fine for weeks, then all of a sudden it's like this now.
     
  3. jillefresh macrumors newbie

    Joined:
    Jun 18, 2008
    #3
    It's a problem that a lot of people are having. From what I've read, Apple is looking into it. Mine does it too, just started randomly Sunday, and it's VERY annoying. I can't even get through an hour's worth of usage without death of phone. Sometimes mine gets stuck on a certain percentage, and the next time I check it, it will be dead. We can only hope they come out with an update and soon. Also, I think that some people are having success restoring the phone as new, not from a backup. I'm not even going to waste my time trying, because I'm sure it won't help!
     
  4. tyte07 thread starter macrumors newbie

    Joined:
    Sep 30, 2009
    #4
    I thought people were having that problem because they upgraded to 3.1. I'm still on 3.0 and have never upgraded to 3.1 before. I want to restore my phone with 3.0 again, but from what I've read, that's not possible right now.
     
  5. tyte07 thread starter macrumors newbie

    Joined:
    Sep 30, 2009
    #5
    I've also noticed that when I look at my Usage and Standby times, all I see is a dash with no numbers with both of them.
     
  6. tyte07 thread starter macrumors newbie

    Joined:
    Sep 30, 2009
    #6
    Is there a way for me to restore it back to 3.0?
     
  7. nehunte macrumors 6502

    nehunte

    Joined:
    Apr 30, 2009
    #7

Share This Page