iPhone 3GS cannot unlock for three UK!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Gen2, Nov 22, 2009.

  1. Gen2 macrumors newbie

    Joined:
    Nov 22, 2009
    #1
    I've got an iPhone 3GS on 3.1.2. I did a fresh restore then unlocked it using blackra1n because I had a Three UK SIM card and needed to hacktivate it. Once that was done, I went ahead and downloaded blacksn0w and unlocked it. The problem is that there is only a 'No Signal' displayed in the top left corner. It is baseband 05.11.07 and I know that the SIM card is fine because it works in my friends iPhone the same way. It worked in this iPhone when I did it before, but I had to restore after a friend mucked with my iPhone.

    Is there anything I can do? Any help would be appreciated. Thanks.
     
  2. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #2
    Not sure with the baseband but recently had someone bring their 3GS into my shop and it was on 3.1.2 and was on '3'
    It wasn't jailbroken though, all I can presume was that it was a factory unlock although the guy didnt know he just said he bought it off someone like that.

    I should have checked the baseband out really but I would presume that if he had 3.1.2 he would be on the latest baseband as well. But cannot confirm.
     
  3. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #3
    No signal or "No service"?

    When i first put a T-mo SIM in after unlocking, it showed "No Service" for a minute or two, then connected and it was fine.
     
  4. Gen2 thread starter macrumors newbie

    Joined:
    Nov 22, 2009
    #4
    It's not temporary. It's permanently at no signal and I remember I dd something really stupid that made it work last time. Something like restoring to a custom ipsw, activating it with an O2 SIM card, then using blackra1n+blacksn0w and it worked right away. Thanks though.
     

Share This Page