Iphone 3GS Charging With This Accessory Is Not Supported

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ztphonehome, Feb 17, 2011.

  1. ztphonehome macrumors newbie

    Joined:
    Feb 17, 2011
    #1
    Hi everyone, I just bought a replacement iPhone from the Apple Store using out of warranty replacement so I am guessing that it is refurbished. I updated it to 4.2.1 firmware and then jailbroke it with redsnow 0.9.6b6 and then rejailbroke it with greenpois0n to make the jailbreak untethered. After that I unlocked it and for a few hours it was working great. My problem is that only a short while after it refused the charging cable which was working fine earlier and gave me the error "charging with this accessory is not supported." I should also not that to unlock on 4.2.1 I had to update to iPad baseband 6.15. I have been trying to solve the problem by hard resetting the phone (by holding home and power until the apple logo reappears), and by soft resetting through the settings panel. Yesterday I did have a breakthrough by rejailbreaking with both tools (I think) and I managed to get it to charge again for another day, but today I am left in the same position with the error message reappearing every time I plug in a usb. Syncing works fine, so I know that it is at least able to establish some connection and it charges VERY slowly if left plugged in to a wall outlet, although it will still display the charging is not supported screen when it is charging. I know the problem isn't just the cable because I have tried at least 4 or 5 apple usb cables. I thought the problem might have had something to do with the iPad baseband (although I know very little as to how baseband affects something like this) so I bought an Apple iPad charger to test that with still no luck. I am not unsure of what to try, and I can't take it back to the Apple Store because it is impossible to restore to a stock firmware until a solution is released which allows downgrading 6.15 baseband. I believe I have the new bootrom. Thanks in advance for any suggestions.
     
  2. oakie macrumors 6502

    oakie

    Joined:
    Oct 16, 2008
    Location:
    seattle
    #2
    really hard to know what's going on since you didnt ensure the device was 100% functional before jailbreaking using the iPad baseband hack.

    but it's not the use of the iPad baseband itself since the baseband only controls the function of the radios.
     
  3. ztphonehome thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #3
    Thanks for the info good to know. Is there any possibility it could have something to do with the fact that I stacked two jailbreaks on top of each other? Unfortunately your correct and I could have just gotten a faulty iPhone in which case I'm out of luck.
     

Share This Page