iPhone 3Gs composite video out

Discussion in 'iPhone Accessories' started by djltoronto, Dec 29, 2009.

  1. djltoronto macrumors member

    Joined:
    Dec 22, 2009
    #1
    Looking for a way to output video from my iPhone 3Gs to a TV with composite input.

    Preferably without the use of a dock!
    Does anyone know if this is possible?


    I searched and found - http://support.apple.com/kb/HT1454
    Which says my 3Gs is not compatible with the composite video cable unless I use a dock!

    Can someone please clarify this for me?

    iPhone 3Gs, 3.1.2(7D11)

    Thanks
     
  2. the1payday macrumors 6502

    the1payday

    Joined:
    Jun 19, 2007
    Location:
    Amarillo, TX
    #3
    I have the Composite cable (red, white, and yellow ends) with an iPhone 3GS and I have never had a problem with it. That is strange that Apple's support page shows it as being "Unsupported" with the 3GS.
     
  3. grockk macrumors 6502

    grockk

    Joined:
    Mar 16, 2006
    #4
    I have a composite cable like the one the OP is tyalking about and it works just fine to play on my TV. I use the S-video and RCA Audio and have the USB part plugged into a power adapter. Maybe it thinks it's in a dock? Dunno but it does work.
     
  4. djltoronto thread starter macrumors member

    Joined:
    Dec 22, 2009
    #5
  5. djltoronto thread starter macrumors member

    Joined:
    Dec 22, 2009
    #6
    Very strange that it works, but claims to not be supported. :confused:
     
  6. djltoronto thread starter macrumors member

    Joined:
    Dec 22, 2009
    #7
    :confused: you use the S video? Of the composite cable?


    I'm looking for composite video (typically the yellow RCA connector)
    Apple site says it will not work, but the1payday says his is working.




    I don't want to buy a cable only to have it stop working with the next software update!
     
  7. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
  8. djltoronto thread starter macrumors member

    Joined:
    Dec 22, 2009
    #9
  9. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #10
    In doing more research, it seems as if they have made 2 versions of the cable. The support doc that say "not" only mentions MB129LL while the current versions being sold are MB129LL/B. Maybe the reason for the discrepancy?
     
  10. djltoronto thread starter macrumors member

    Joined:
    Dec 22, 2009
    #11
    That sounds about right, that has to be it.
    Thanks again.
     
  11. ozarkman macrumors newbie

    Joined:
    Jan 1, 2010
    #12
    Just bought the MB129LL/B

    Just bought the MB129LL/B composite AV cable and it's not working on my wife's 3GS. The darn thing wont recognize the cable. No errors or any indication that it's been plugged in. If we completely shut off the iphone by holding the power button down and sliding the power off slider there is brief snow on the screen upon power up.

    Any ideas, or should I just take this cable back to wally world?
     
  12. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
  13. djltoronto thread starter macrumors member

    Joined:
    Dec 22, 2009
    #14
    On my 3Gs, you can't turn TV out on or off. It's always on.
    You can just switch from PAL - NTSC & turn widescreen on or off.. there is no TV out on /off setting. It's always on
     
  14. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #15
    You are absolutely right...I don't know why I thought you had the option to turn it on off.
     
  15. djltoronto thread starter macrumors member

    Joined:
    Dec 22, 2009
    #16
    So now that ozarkman has tried MB129LL/B - and that didn't work...
    WTF am I supposed to do?

    This really should be easier than this!


    Are there any experts on this forum?
     
  16. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #17
    Buy them and return them if they don't work. Mine work great.
     
  17. nickE10mm macrumors newbie

    Joined:
    Jan 29, 2010
    #18

    Thought I'd chime in here ... I just bought the "/B" model of the AV cables and they don't FULLY work on my 3GS with my Samsung widescreen. First time I plugged them in, I couldn't get ANYTHING to work. I then rebooted my iPhone and it then started working for iPod Video but not iPod Audio (ie, MP3's, etc). Just a black screen. I'm using 3.1.2 firmware. I bought the standard Apple Dock (NOT the Universal version) at the same time and found that, while the DOCK is plugged in inline with the AV cable, the AV cable didn't work at ALL.

    In other words, Apple's accessories don't seem to work at all. I'm bummed and the stuff is all getting returned.
     
  18. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #19
    It was always made clear to me that a standard dock would not work with the AV cables, but what do you mean by no music? No audio comes out, or you just don't see album art?

    If you mean just album art, then this is something I would never notice. If I am trying to show a video, then I hook it up to the TV. If I am just playing music, the tv is not on.
     
  19. nickE10mm macrumors newbie

    Joined:
    Jan 29, 2010
    #20
    No music at all and obviously no album art, as that isn't supported from what I understand. What's crazy is that, when playing movies via the iPod program, both video AND sound works.
     
  20. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #21
    These people say it is your tv. It will ignore audio signals if no video.

    http://discussions.apple.com/thread.jspa?threadID=1943061&tstart=0
     
  21. nickE10mm macrumors newbie

    Joined:
    Jan 29, 2010
    #22
    I belive that you have found the solution! Thanks so much for posting this link...it has kept me from going crazy trying to figure it out. Makes TOTAL sense that it's the TV.

    I'll just keep my cables and test some of these methods which should work. I'll report back....
     
  22. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #23
    You're welcome.

    One "issue" I found is that if you are playing long videos from the camera roll(not the iPod), you have to turn off "auto lock" in general settings or your video will stop playing when the phone goes to sleep.
     
  23. nickE10mm macrumors newbie

    Joined:
    Jan 29, 2010
    #24
    I'll keep that in mind.
     
  24. dlangpap macrumors newbie

    Joined:
    May 2, 2011
    #25
    Help with Iphone 3GS TV out

    Hi,

    Ok so here's my story trying to play a video file I have on my Iphone 3Gs on my TV.

    I got the .avi file on my computer. I get Buzz player. The file plays great on the Iphone but does not transfer to TV. Apparently only Iphone 4 is supported.
    I download Handbrake to transform .avi to .m4v and transfer the file to my Iphone via Buzz. It does not play on the TV.

    I try to sync the video via Itunes. It says that it has to replace all my music for the video to be transferred. I find this funny since I had already downloaded the file via Buzz, so it seems it is not a matter of space. For the sake of making this work, I do it. So I try to play the video from the Iphone's Ipod, but when connected to the TV, the file crashes after opening even though it plays fine just on the Iphone. Finally, I try running the video from "Photos" on Iphone and it works. However, there are constant black screen interruptions (every 5 secs or so) on the video when played on the TV.

    So now I don't know how to proceed. Is it a problem of the AV cable (cheap made in China one) and should I get one from Apple for US$ 60? Kind of risky if it's not a problem with the cable...

    Or is it a problem with the Iphone? Any ideas or suggestions welcome.

    In any case, if someone knows of a better way to transfer the video to the Iphone and then being able to play it for TV out without having to erase all my Itunes music library from it, that would already be a great start.

    Thanks.
     

Share This Page