iphone 3GS crashing and weird lock bug on iOS6

Discussion in 'iOS 6' started by eyron, Sep 21, 2012.

  1. eyron macrumors newbie

    Jul 1, 2012
    Have been running iOS5 fine on my iPhone and have even reverted at one point which solved all the issues.

    1. At around 20% battery if I attempt to unlock the phone or even if it is running an app the screen will simply go black, there's no obvious shut down process. I can then boot up again and it reports the same ~20% battery and runs fine for the remainder. This has happened 3 times now.

    2. After a reboot the unlock slider is unresponsive. I have to mess around turning the screen off and then using the camera slider to get in.

    Has anyone else experienced these issues? I'm thinking of reverting to 5.1.1 as it's unlikely they will bother fixing them if they're 3GS specific. Don't want to lose the iMessage link with iPad and OSX though, and can't work out if I would?
  2. eyron thread starter macrumors newbie

    Jul 1, 2012
    Can anyone say if they have or haven't experienced these issues with the 3GS?
  3. mac00l macrumors 6502

    May 3, 2011
    Mine seems to be working just fine in that regard
  4. dazed macrumors 6502a

    Jun 23, 2007
    I don't have these issues. The update screwed up my phone so I needed to do a restore from backup but after that was complete its all working fine and actually seems a little bit faster.
  5. BittenApple macrumors 6502a


    Nov 29, 2008
    I have experienced both of those problems on my 3GS. Basically a bug!
  6. eyron thread starter macrumors newbie

    Jul 1, 2012
    Interesting that some have and some haven't, I've submitted a bug report to apple anyway. I've experienced the problems with a restore and without on the Beta 1 and final releases.
  7. kyjaotkb macrumors 6502a

    Nov 20, 2009
    London, UK
    I updated mine using the "restore" method. It is faster than I've ever seen it under iOS 4 or 5. Even faster than my girlfriend's iPhone 4 (she just "updated" it) actually.
  8. eyron thread starter macrumors newbie

    Jul 1, 2012
    I'm not complaining about speed, I accept that the 3GS is going to be slow now it's 3 year old, I just need it to be reliable. You'll probably find it will return to the speed of iOS5 with some usage.
  9. Thetonyk123 macrumors 68000


    Aug 14, 2011
    3GS runs fine here, try a restore from backup maybe?

Share This Page