iPhone 3GS data not working, no 3G in 3G area

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Amatatomba, Jul 18, 2010.

  1. Amatatomba macrumors newbie

    Joined:
    Jan 31, 2010
    #1
    I have an iPhone 3GS, purchased in March of this year. It's worked great except one thing: twice so far my phone has been displaying full bars and EDGE while my mom's iPhone 3GS displays full bars and 3G. When this happens, I can make phone calls and send text messages, but I can't get on Safari or anything else that uses data.

    The first time this happened (about a month and a half ago), I just turned off my phone, removed the SIM card and put it back in, and let it sit, turned off, for about an hour. Then when I turned it back on, it was fine.

    This time, I have tried that to no effect. It's not simply that I have bad coverage where I'm at or no 3G because my mom's phone works fine. I recently updated to 4.0.1, if that makes any difference (my mom has not).

    Is there any fix for this I can try myself? Or should I take my phone into AT&T and let them deal with it?
     
  2. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #2
    What you describe is usually a network problem.

    Are you both on the same network?
     
  3. zepo macrumors newbie

    Joined:
    Aug 20, 2009
    #3
    same problem with iPhone 3G

    I'm having the same problem with my iPhone 3G... "Safari cannot open the page," "update failed" in Weather, etc. whenever on the 3G network. It's been a couple days now. Works for a minute if I toggle data off/on but then fails again.
     
  4. monstermutt3007 macrumors newbie

    Joined:
    Jun 5, 2008
    #4
    3GS 3G Problem!

    My 3GS is doing the exact same thing! I updated to 4.0.1 today and I came into a 3G network ( I live in edge ) and my data went away! It just said AT&T with five bars and no edge or 3G. I went and disabled 3G and I can get edge in the 3G area. But when 3G is still enabled I can't get data at all. I had 4.0 this morning and I was in a 3G area and I had 3G. I think the update did something to it.

    Well I took out my sim reinserted it. No go. I turned it off no go. I'm going to restore it tonight to see if that helps. If not going to apple store tomorrow :(
     
  5. Amatatomba thread starter macrumors newbie

    Joined:
    Jan 31, 2010
    #5
    Well, I feel like an idiot. The problem was as simple as having Enable 3G turned off (Settings > General > Network). I must have turned that off a month ago before I left for Europe and forgotten about it. The first time I had a problem with it, it must have been something different (which would make sense since that went away on its own).
     

Share This Page