iPhone 3GS dies after removing charging-cable!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Danielphoto, May 5, 2013.

  1. Danielphoto macrumors newbie

    May 5, 2013
    Hello there good fellas!

    I'd like to start by apologize if im making a "double-thread", but i've been searching the internet like crazy for information that might help me!

    So heres the story:

    I bought a iPhone 3GS from a friend of mine, but it was locked to a swedish netprovider called Telenor, and im using Halebop GSM on my old phone (non-iphone)
    So i started looking up how to unlock it, and also gathering info and files needed, and eventually i started jailbreaking/unlocking the phone.

    When i bought it, it was running iOS 5.0.1 with BB 05.16.05.
    I used Redsn0w to create a custom IPSW using the "official" iPhone2,1_5.0.1_9A405_Restore - IPSW.

    After the jailbreak it run on iOS 5.0.1 and BB 06.15.00 (?, the Ipad baseband), and everything seemed to work just fine! (I used Ultrasn0w to unlock it).

    I finished quite late in the night, so i just took the phone with me to bed and played a bit with it before i felt asleep.
    When i woke up, i removed the charging-cable and put it in my pocket, but like 3-4 minutes later when i was gonna check the time, it had died! Hmm, strange i thought, and booted it up with redsn0w again, and all seemed fine! (again)
    Then the same thing happend, and again, and again! Eventually the phone didn't boot, it just stopped with a white screen!
    I read that one way of fixing that, was either to let the battery drain, or to remove the battery for a while, so i opened it up and removed the motherboard for a couple of minutes before i reassembled it again, and this time it got stuck in DFU-mode, or at least that's what i think happend, cause redsn0w didn't wanna boot it (didn't get to the white screen).

    This is where it all gets a bit dizzy, though my memory really isn't the best in the world, but i used redsn0w and "mounted" the custon IPSW that i created earlier to boot it and jailbreak it again.
    Now i got really happy, cause it now booted up as it should and i finally got back into the phone!
    Somehow though, im now running iOS 5.0.1 (still), but BB 05.13.04, which is working fine for my SIM-card!

    The PROBLEM however remains, as soon as i remove the phone from the charger and not use it for like 3-4 minutes, it dies!!
    I also tried installing Corona, in order to get rid of the need of a computer to boot it!
    I tried finding solutions for this problem for two days now, and i cant get my head around it! :/

    Please, if you got any idea, help me out!

    PS: This is my first JB/unlock, but i normaly have quite easy understanding and working with this kind of stuff.. So if iv'e missed something, please tell me! :)


    I should also mention that when i try using iTunes to reset the phone, it wont accept any other than the custom ipsw that i created, otherwise it just gives me the "error 3194" :/
  2. Danielphoto thread starter macrumors newbie

    May 5, 2013
  3. MrMacMack macrumors 6502a

    Oct 24, 2012
    Was the phone dying like this before you did all the above you mentioned?
  4. Danielphoto thread starter macrumors newbie

    May 5, 2013
    No, i only used it briefly before, but then it was up and running 1 hour+ with no problems!

    Really annoying, everything works smooth and fine, but as soon as i let it be idle for about 5 minutes it just goes black and doesn't react neiter to the power or home bottom! :(

    EDIT: Thanks for the reply btw! :)
  5. Danielphoto thread starter macrumors newbie

    May 5, 2013
    Ask what? Why the phone wont work properly after i jailbreaked it? The guy i bought it from is a "no-tech-guy" if you know what i mean! :p
    That's why i faced this forum, i reconed that someone here might have a clue about technology! ;)
  6. Ann P macrumors 68020

    Jun 29, 2009
    I might be way off but check for water damage. I bought an iPod touch a few months ago; it would stay on but only with a cable plugged in. Took it to the Apple store and they told me it had been submerged in water.
  7. Danielphoto thread starter macrumors newbie

    May 5, 2013
    Well, that might be an idea, but the thing i dont understand, is how it could work flawless (concidering the function to stay on without the power-cable) before i jailbreaked it, but now, after the JB, it dont!
    i mean, it's not like i put it in water meanwhile i JB'ed it! ;) :D
  8. MrMacMack macrumors 6502a

    Oct 24, 2012
    I think what she may be saying is that if it had been exposed to liquid that the affects may now finally be showing. See if either of the liquid indicators have been tripped.

  9. Danielphoto thread starter macrumors newbie

    May 5, 2013
    Okey! :)

    Well, the phone didnt show any of the signs shown in the link you sent, so i guess that's a good thing? :)
  10. Danielphoto thread starter macrumors newbie

    May 5, 2013
    Okey, some update!

    Iv'e found out that you can find crash-logs on the phone, and quite a few of them were "LowMemory"-crashes! Turned out that there were severeal apps running in the background, and learnt about double-tapping the home buttom to be able to close them.. did so, and thought that the problem might be solved now, but i couldn't have been more wrong, cause the problem is still there, but now im not reading any new crashlogs! :(
  11. Danielphoto thread starter macrumors newbie

    May 5, 2013
    This is a crash report that i got a couple of days ago:


    The file is called "log-bb-2013-05-05-stats" and was found in Logs>CrashReporter>MobileDevice>"PhoneName">Baseband

    This is one of the LowMemory-reports from yesterday before i learnt how to shut down app's running in the background:

    Incident Identifier: 64244052-E6E3-449D-84FE-C9E9858D3A36
    CrashReporter Key: 29debfb1affe19113cfbd79fb7a270eb492dcd9e
    Hardware Model: iPhone2,1
    OS Version: iPhone OS 5.0.1 (9A405)
    Kernel Version: Darwin Kernel Version 11.0.0: Tue Nov 1 20:33:22 PDT 2011; root:xnu-1878.4.46~1/RELEASE_ARM_S5L8920X
    Date: 2013-05-08 09:07:22 +0200
    Time since snapshot: 39 ms

    Free pages: 583
    Wired pages: 11507
    Purgeable pages: 0
    Largest process: AppStore

    Name UUID Count resident pages
    Music~iphone <18bda5f883623f3a8f78902464292fe0> 752
    calaccessd <e4ae542d0b693433a57e79c72cb1f033> 405
    Reminders <f2f4df9122933f4d8af88dff2043af54> 936
    MobileTimer <714348f459ea3ebabf700707151882d5> 839
    Facebook <3e48419caebb37469a8172f296909778> 1253
    Instagram <a04d4c0e91823cc8a35a951e8f9dd50f> 6465
    Flickr <76d6f61e0e0a3f5b8b9e27ef45ce6b46> 4091 (jettisoned)
    MobileMail <7064f2baf3f23db987bc8ec99855fe53> 810
    AppStore <3276f9733bb63affb9a42180684fe4de> 12025
    installd <b878bd4ad7f5302d99bd742ce785c4a2> 321
    syncdefaultsd <d6883ac15a443a19b338514a4c1ca523> 763
    MobilePhone <fe38c6944a053c9187b41ee50aa151b0> 1111
    BTServer <e03baab8e0103188979ce54b87591065> 410
    aggregated <68a25a1690cb372096543a46abed14d7> 294
    apsd <e4b6e6e4f31e36f79815747ecbf52907> 290
    fairplayd.N88 <e268bdce5e693e45a8a7d9c8434b6159> 160
    fseventsd <78af02202422321885dfc85c24534b0e> 167
    iapd <3ee7f82879033b4fb93b9cf1f4ecae29> 348
    imagent <8e2042f2ec9e3af9ba400f031f1bbfa7> 356
    locationd <91c84ab19dd03e4ab1b4cc30178ab1c0> 556
    mDNSResponder <b75f43f012ad3d9ea172d37491994e22> 217
    mediaremoted <b9fa7d1381013c2fa90ea134ff905f59> 263
    mediaserverd <478e5e8345c83be5ba1868906813bb75> 838
    ubd <7eaf0b0ca5b83afabecb0dfaa38c7a19> 290
    wifid <e176ab123beb3000bdb89e020612c1d6> 271
    powerd <25ddef6b52e4385b819e777dd2eeed3c> 148
    lockdownd <a68aa1526ef13a9bb4426bb71ffc1e3c> 211
    CommCenterClassi <3ef6d0094b5c39d3b77e558ad3018d24> 596
    SpringBoard <7506c20d86da3f1dbe9bf38f8bda253d> 4873 (active)
    configd <3430c0025ed13f56800a329b7254d2ae> 337
    syslogd <dd3766bcb1213e91b66283635db09773> 110
    notifyd <3793fabace3a385687b3c29c1fa1fcac> 205
    UserEventAgent <6e1cabc1ec6d372c90a6bdeaa7b258fa> 332
    launchd <cc35dd7a872334319ed028e6bbeae081> 191


    Can anyone make any sense from this?! :)
  12. applejuice99 macrumors member

    Apr 1, 2013
    I'm generally not good with jail-broken devices as i have not jail-broken anything. But it sounds as if your battery has been shorted, normally done by water damage. To sort that out you would need to change the battery, but seeing that it is a 3GS it may not be worth investing in a new battery, however it is up to you.
  13. Danielphoto thread starter macrumors newbie

    May 5, 2013
    Okey, thanks for that answer! :)

    I might try that out actually, i bought the phone for about 40 Euro, and a new battery here in town costs about 20 Euro, so its not too much money! :)
  14. Danielphoto thread starter macrumors newbie

    May 5, 2013
    Okey, i tried changing the battery, but it didn't even wanna boot with the new battery (and yes, i dubbelchecked all connections/connectors), so i swapped back to the original and then it started! :mad:
  15. TheRainKing macrumors 6502a


    Jun 11, 2012
    Sounds like the new battery was faulty.
  16. annaharris macrumors member

    Aug 21, 2012
    San Francisco
    It's an jailbreak problem I guess. Because after running redsn0w your iPhone goes blank after 2 or 3 hour right? So maybe jailbreak kill your iOS that's why it's happening. Install new iOS in your iPhone then use if for a day or until it stop working. If there is jailbreak issue then your iPhone will work fine or will find some other solution for it...

Share This Page