iPhone (3GS) GPS not working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by horrgakx, Nov 23, 2010.

  1. horrgakx macrumors member

    horrgakx

    Joined:
    Dec 5, 2007
    Location:
    UK, North West
    #1
    I'm having trouble with GPS on my iPhone. It's a 3GS running 4.1.

    Basically, it's not picking up a signal. I've tried the obvious as in checking the settings for Location Services, I've tried outdoors in a wide open space and I've also restored the iPhone in case it was a software glitch.

    I've put my phone next to my mates' phone and his works fine. Mine just won't pick up a signal on the Maps application or any other app that uses GPS such as RunKeeper, MotionX or CoPilot. It might be worth mentioning that I nolonger get the message "xxx would like to know your location; Allow/Don't allow".

    I jailbroke it a couple of weeks ago but because it stopped my AV cable working I pushed the original Apple 4.1 version back on to it and the AV lead works. GPS doesn't.

    Can anyone shed some light on what I need to do please?
     
  2. horrgakx thread starter macrumors member

    horrgakx

    Joined:
    Dec 5, 2007
    Location:
    UK, North West
    #2
    It was suggested that I reset to "factory default" - is the menu option called "Reset all settings"? as I can't find the word 'factory'.
    I have however upgraded to 4.2 last night but the same fault is present.

    Is upgrading from 4.1 to 4.2 the same thing as "Reset all settings" or is it categorically different?
     
  3. horrgakx thread starter macrumors member

    horrgakx

    Joined:
    Dec 5, 2007
    Location:
    UK, North West
    #3

Share This Page