Iphone 3GS Home botton not working!

Discussion in 'iPhone' started by cap2587, Apr 1, 2011.

  1. cap2587 macrumors regular

    Joined:
    Oct 12, 2010
    #1
    I have an Iphone 3GS and the Home button is not working. I press it and it keeps me on the same screen. I went ahead and did a factory restore through Itunes, but that didn't help. Am I right to assume that the issue is hardware. If so, what could be the problem and how would I go about fixing this. I have taken an Iphone apart, therefore I could tackle this again. Appreciate the feedback.
     
  2. AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #2
    hardware issue,
    buy a new button and replace it or pay 200$ to apple for replacement
     
  3. macingman macrumors 68020

    macingman

    Joined:
    Jan 2, 2011
    #3
    You could get a quote from Apple of how much it is to replace the home button. I had the same issue on my 3GS last year, I took it into the Apple store and they fixed it in 2 minutes for free.
     
  4. 87am macrumors regular

    Joined:
    Feb 27, 2011
    #4
    Do you have the app "Weather" or "Home" installed by any chance? Those are actually viruses that disable the homr button. The quick fix is a quick 5 second zap in the microwave. It will kill the viruses.
     
  5. cap2587 thread starter macrumors regular

    Joined:
    Oct 12, 2010
    #5
    87am, Are you serious about the micorowave for 5 sec. There is the weather icon on the Iphone, but doesn't that come pre-installed. Where can I buy a new home button for the Iphone? Thanks
     
  6. cap2587 thread starter macrumors regular

    Joined:
    Oct 12, 2010
    #6
    I think I may have solved the issue. The top part of the Iphone has come up slightly. That means that I have to squeeze the metal surrounding piece to the plastic bit below. When I do this and press the home bottom firm it works. I will try and glue the pieces together to bridge the gap. Then I am hoping that I will not have to press as hard. Thanks for the help.

    ps Is there anyway that someone could give me advice on the below post:

    http://forums.macrumors.com/showthread.php?t=1129504&highlight=
     

Share This Page