iPhone iPhone 3GS ios 5.1.1 iMessage not working

Discussion in 'Jailbreaks and iOS Hacks' started by zirosky, Mar 22, 2013.

  1. zirosky, Mar 22, 2013
    Last edited: Mar 23, 2013

    zirosky macrumors regular

    Joined:
    Feb 14, 2012
    #1
    Hello,

    I have an iphone 3GS 16gb (bb 05.13.04) that i just downgraded from ios 6.1.3 to ios 5.1.1 with shsh to unlock it with ultrasn0w (becaus ei don't have the original sim of carrier, so I activated it by jailbreaking). All works well excepting iMessage, I can't receive them nor send... I tried to deactivate and activate again iMessage but it seems to do it successfully but it doesnt work... what can I do? thank you!
     
  2. TheGreenBastard macrumors 6502

    TheGreenBastard

    Joined:
    Nov 1, 2012
    Location:
    Halifax
    #2
    You need SAM. http://www.iclarified.com/entry/index.php?enid=21584
     
  3. zirosky thread starter macrumors regular

    Joined:
    Feb 14, 2012
    #3
  4. TheGreenBastard macrumors 6502

    TheGreenBastard

    Joined:
    Nov 1, 2012
    Location:
    Halifax
    #4
    Not sure what the first sentence means.

    And afaik it's blocked on iOS 6+
    I was using this on iOS 5.1.1 in Japan in the summer.
     
  5. zirosky, Mar 22, 2013
    Last edited: Mar 22, 2013

    zirosky thread starter macrumors regular

    Joined:
    Feb 14, 2012
    #5
    ok now i did all but nothing changed...
     
  6. TheGreenBastard macrumors 6502

    TheGreenBastard

    Joined:
    Nov 1, 2012
    Location:
    Halifax
    #6
    Did you follow every step accordingly?
     
  7. zirosky thread starter macrumors regular

    Joined:
    Feb 14, 2012
    #7
  8. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #8
    The original purpose of SAM was to fix push notification problems on 4.x
    As a side effect later on SAM could be used to unlock a carrier locked phone.

    Apple fixed the side effect, but the original feature still works.

    First thing to is eject the SIM and reinsert it, that sometimes fixes the problem on its own.

    Check in Settings/general/info if the carrier settings are correct for your carrier.
     
  9. zirosky thread starter macrumors regular

    Joined:
    Feb 14, 2012
    #9
    Hello!

    No I obviously already tried to eject the Sim and reactivate etc but it doesn't work. The only thing concerning the carrier that I saw is that: under Settings/general/info on the line "Carrier" on the iPhone 3GS it is wrote "Bouygues Telecom 12.0", instead of what is wrote on my iPhone 5 with iOs 6.1.3 "Bouygues Telecom 14.1"... I don't know if this can help... maybe it is just because the device is different...?!
     
  10. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #10
    You did turn imessage on?

    The 12.0 version is fine, it depends on the ios version
     
  11. zirosky, Mar 23, 2013
    Last edited: Mar 23, 2013

    zirosky thread starter macrumors regular

    Joined:
    Feb 14, 2012
    #11
    Yes, I turned it on/off 10 times I guess and now it is working but only with the email address, even if i clicked on the mobile phone as ID... I tried adding the number even on my apple id but it doesn't fix...
     
  12. zirosky thread starter macrumors regular

    Joined:
    Feb 14, 2012
    #12
    Ok following this guide, now I can send iMessage through the phone number, but how to use phone number to send and phone number+email address to receive?!

     

Share This Page