Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

zirosky

macrumors regular
Original poster
Feb 14, 2012
135
8
Hello,

I have an iphone 3GS 16gb (bb 05.13.04) that i just downgraded from ios 6.1.3 to ios 5.1.1 with shsh to unlock it with ultrasn0w (becaus ei don't have the original sim of carrier, so I activated it by jailbreaking). All works well excepting iMessage, I can't receive them nor send... I tried to deactivate and activate again iMessage but it seems to do it successfully but it doesnt work... what can I do? thank you!
 
Last edited:

TheGreenBastard

macrumors 6502
Nov 1, 2012
361
109
Halifax
Hello,

I have an iphone 3GS 16gb (bb 05.13.04) that i just downgraded from ios 6.1.3 to ios 5.1.1 with shsh to unlock it with ultrasn0w (becaus ei don't have the original sim of carrier, so I activated it by jailbreaking). All works well excepting iMessage, I can't receive them nor send... I tried to deactivate and activate again iMessage but it seems to do it successfully but it doesnt work... what can I do? thank you!

You need SAM. http://www.iclarified.com/entry/index.php?enid=21584
 
Comment

TheGreenBastard

macrumors 6502
Nov 1, 2012
361
109
Halifax
i can do it right know of before I have to do something else??? i have ot remove ultrasn0w?

and on th elink it says Apple has BLOCKED this method.

Not sure what the first sentence means.

And afaik it's blocked on iOS 6+
I was using this on iOS 5.1.1 in Japan in the summer.
 
Comment

TriJetHero

macrumors 601
Oct 13, 2010
4,959
144
World
The original purpose of SAM was to fix push notification problems on 4.x
As a side effect later on SAM could be used to unlock a carrier locked phone.

Apple fixed the side effect, but the original feature still works.

First thing to is eject the SIM and reinsert it, that sometimes fixes the problem on its own.

Check in Settings/general/info if the carrier settings are correct for your carrier.
 
Comment

zirosky

macrumors regular
Original poster
Feb 14, 2012
135
8
Hello!

No I obviously already tried to eject the Sim and reactivate etc but it doesn't work. The only thing concerning the carrier that I saw is that: under Settings/general/info on the line "Carrier" on the iPhone 3GS it is wrote "Bouygues Telecom 12.0", instead of what is wrote on my iPhone 5 with iOs 6.1.3 "Bouygues Telecom 14.1"... I don't know if this can help... maybe it is just because the device is different...?!
 
Comment

zirosky

macrumors regular
Original poster
Feb 14, 2012
135
8
You did turn imessage on?

The 12.0 version is fine, it depends on the ios version

Yes, I turned it on/off 10 times I guess and now it is working but only with the email address, even if i clicked on the mobile phone as ID... I tried adding the number even on my apple id but it doesn't fix...
 
Last edited:
Comment

zirosky

macrumors regular
Original poster
Feb 14, 2012
135
8
Ok following this guide, now I can send iMessage through the phone number, but how to use phone number to send and phone number+email address to receive?!

The problem with all of this is that - If you are logged into your Apple ID account on your iPhone, and if your Apple ID account is an email (which it will be), then your email will be used for 'Receive At'. However, if you log out of your Apple ID account, then only your mobile number will be used at 'Receive At'.

Follow these easy steps:

1. Go to 'Settings'>'Messages'>Make sure iMessage is 'ON'
2. Scroll down to 'Receive At - 2 Addresses'>Click on 'Receive At 2 Addresses'. You will see your mobile number greyed out (cannot be clicked), and your Apple ID email address (can be clicked).
3. This means iMessage is using your Apple ID email address and not your mobile number.
4. You need your mobile number to be selected, but it can't because it's greyed out = THE PROBLEM.
5. THE SOLUTION - Click 'Apple ID' at the top (it has your email address next to it). iMessage account screen pops up. Click 'Sign Out'
6. Click back on 'Messages' button. Now you will see only your mobile number in the 'Receive At' field.
7. Test by sending someone a message with iMessage ON. People will now get your messages with your name and mobile number stated instead of your email address.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.