iPhone 3GS iOS4 JB Problems?

Discussion in 'Jailbreaks and iOS Hacks' started by pratstercs, Jul 4, 2010.

  1. pratstercs macrumors newbie

    Joined:
    Jul 4, 2010
    #1
    Hi,
    I have an iPhone 3GS New BootROM currently running iOS 4.0. I have (or had) SHSH blobs on the Cydia server for both 3.1.2 and 3.1.3.
    I have upgraded to stock iOS 4.0, and now cannot restore to 3.1.2 or custom (Jailbroken) 4.0 ipsws (4.0 created in sn0wbreeze), giving 1600, 3014, 1604 and 3194 errors.
    I need the phone jailbroken, preferably on iOS 4.0. It does not need to be unlocked, I am in the UK on O2.
    Any help would be much appreciated?
    Thanks
    Pratstercs
     
  2. Imsuperjp macrumors 6502

    Joined:
    Apr 9, 2010
    #2
    Did you update your host files to redirect iTunes to cydia instead of apple?
     
  3. pratstercs thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #3
    Yes, has been in place for months.
    Check: 74.208.10.249 gs.apple.com
     
  4. ToroidalZeus macrumors 68020

    ToroidalZeus

    Joined:
    Dec 8, 2009
    #4
    After you restore and get the errors, use TinyUmbrella to kick the iphone out of recovery mode.
     
  5. pratstercs thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #5
    I have no problems getting in/out of recovery or DFU modes, the problem is that i'm stuck on vanilla iOS4 and can't restore to JB'd iOS4 or below.
     
  6. OverSpun macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #6
    how do I check my 3GS with oldbootrom or newbootrom? Im learning about JB+UL my 3gs
     
  7. pdpfilms macrumors 68020

    pdpfilms

    Joined:
    Jun 29, 2004
    Location:
    Vermontana
    #7
    I thought new bootrom 3GS's were unable to be jailbroken on iOS4 at this time...?

    http://blog.iphone-dev.org/
     
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    Correct
     
  9. wanzer macrumors member

    Joined:
    Jun 26, 2010
    #9
    Not possible to downgrade with the new bootrom. Doesn't matter if you have the SHSH blobs backed up or not, those only matter for the old bootrom 3GS's.
     
  10. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #10
    Old or new bootrom 3GS can be downgraded using Saurik's method if hashes are saved.
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11
    Thats false.
    You can downgrade any bootrom old or new if you have SHSH's saved for the particular built.
    What you cant do with a new bootrom 3GS is update to custom pwnage 4.0 IPSW
    Only old bootroms you can since the bootrom is pwned and the new bootrom is not thats why its a tethered JB.
    I think thats where the confusion came on your part.
     
  12. TZRaceR6 Guest

    TZRaceR6

    Joined:
    Jun 8, 2010
    Location:
    United Kingdom
    #12
    In the same boat mate. I have a 3GS on iOS 4 with O2 as well. Will be nice if this gets figured out.
     
  13. wanzer macrumors member

    Joined:
    Jun 26, 2010
    #13
    Sorry for the rookie mistake, thanks guys for clearing that up. Hopefully a 4.0 JB for the new bootroms are coming out soon :)
     
  14. ToroidalZeus macrumors 68020

    ToroidalZeus

    Joined:
    Dec 8, 2009
    #14
    I downgraded my NEW bootrom iPhone 3GS from 4.0 Final to the official 3.1.3 earlier today, so obviously it does work.
     
  15. sammy2066 macrumors 6502a

    Joined:
    Oct 3, 2007
    #15
    Can't we use someone else's SHSH blobs? I have a friend's 3GS that's absolutely stock running iOS4 on the new bootrom. Never been jailbroken using anything ...

    Please assist ...
     
  16. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #16
    They are unique to each phone. You cannot downgrade without "your" SHSH saved.
     
  17. pratstercs thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #17
  18. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #18
  19. pratstercs thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #19
    Doesn't every downgrade or JB for iPhone 3GS require 3.1.2/3.1.3 SHSH blobs?
     
  20. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #20
    Downgrade yes. Not every jb though. There is userland jb's like spirit that don't require shshs and bootrom doesn't matter.
     
  21. whyrichard macrumors 68000

    Joined:
    Aug 15, 2002
    #21
    urgh! so complicated! these hacks are so un-apple-like!

    r.
     
  22. pratstercs thread starter macrumors newbie

    Joined:
    Jul 4, 2010
    #22
    I meant for iOS4 on 3GS *facepalm*.

    Because they aren't made by Apple and Apple are trying to make it as difficult as possible for people to jailbreak
     
  23. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #23
    There should be a userland spirit type of JB for 4.0 that will work for all 3G, 3GS and even iPhone 4's.
    Stay tuned and be patient.
     
  24. whyrichard macrumors 68000

    Joined:
    Aug 15, 2002
    #24
    it was a joke.


    r.
     

Share This Page