iPhone 3GS Keyboard lag/stutter in SMS app?

Discussion in 'iPhone' started by fr0, Aug 26, 2009.

  1. fr0 macrumors member

    Joined:
    May 6, 2004
    #1
    Hey Gang,
    In the last week or two I've noticed a pretty significant lag when I am typing in the SMS app. Is anyone else experiencing this issue? If so, have you found a way to correct it? I'm running 3.0.1.
    Thanks,
    fr0
     
  2. Prospekt macrumors regular

    Joined:
    Jul 5, 2009
    #2
    Turning the phone off than on again should actually help, if you haven't done it already :)
     
  3. Kyeris macrumors 6502

    Joined:
    Jul 19, 2008
    Location:
    Somewhere in Texas
    #3
    This is just something that happens (on the 3G and 2G at least). Restart your iPhone (as mentioned before) or restore if it's really killing you.
     
  4. lollicup macrumors regular

    Joined:
    Aug 20, 2009
    #4
    you probably have a 3G and not a 3GS

    its because 3.0 introduced copy and paste, which introduces lag whenever you start a text box :(
     
  5. fr0 thread starter macrumors member

    Joined:
    May 6, 2004
    #5
    No, I definitely have a 3GS, unless they started making a 32GB 3G... I've restarted a few times, but it doesn't seem to do much.
     
  6. fr0 thread starter macrumors member

    Joined:
    May 6, 2004
    #6
    Bump, plus, the lag is spreading. My phone just feels rather unresponsive in general. I.e. I press the home button to wake it up and there is a noticeable pause. Am I the only one this is happening to?
     
  7. bboucher790 macrumors 65816

    bboucher790

    Joined:
    Mar 23, 2007
    #7
    I've never experienced serious lag in any part of the OS with my 3Gs. This wasn't the case with my 3G. I love my lag-free 3Gs. I would try resetting as others have said, you can also set your phone to "like new" settings without deleting / reinstalling the OS. That may help, but most likely a full cleaning of the phone may be needed if your issue is that noticeable.
     
  8. RTiii320 macrumors 6502a

    RTiii320

    Joined:
    Aug 15, 2008
    Location:
    Long Beach, CA
    #8
    I have a 3GS as well and have not notice any lag at all (thankfully), I would try a full restore, it that does not work, then try to restore and set it up as a new iphone. Try those two steps, and let us know how it goes.
     
  9. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #9
    I've not noticed a lag with my 3GS 32GB iPhone; if anything it's more responsive and faster to the touch for me....sorry
     

Share This Page