iPhone 3gs - Locked to telstra (?) on plug into itunes screen.

Discussion in 'Jailbreaks and iOS Hacks' started by gazzzzzzzzzza, Sep 13, 2010.

  1. gazzzzzzzzzza macrumors newbie

    Joined:
    Sep 13, 2010
    #1
    Hey,

    So anyway I was given an iPhone 3gs which was working, with i believe 3.1.0 locked to telstra. It was then jailbroken, not sure what was used. then someone tried to unlock the carrier and farked it up.

    Anyway when i got this 3gs it just had the screen - 'connect to itunes'
    I tried forcing a restore with 3.1.1, 3.1.0 and 3.1.0 but it would never let me install the os.
    As well as truing to use 'recBoot' to take it off the connect to itunes screen didnt work.

    Used the iTunes to install the latest iOs4. Now i cant get passed the screen in itunes to insert a sim card (thats valid). Tried with a friends telstra and optus sim and still have the same screen.

    What steps should i take now to get it jailbroken and unlocked?
    i find this topic difficult to google help for as i dont know all the terms and what to ask for.

    thanks for the help

    Cheers
     
  2. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    When you restore the Firmware on an Iphone it needs to be activated. You need a SIM card from the original carrier to activate the phone. Since you said you already tried Telstra and Optus it sounds like its neither of these.

    Check your model number against the list in this link and you may be able to determine the country in which it was purchased.
    http://forum.gsmhosting.com/vbb/archive/t-994747.html

    You said you restored to the latest firmware which means 4.1 There is presently no Jailbreak or unlock for that version.

    There is also the possibility to activate with a phonebook card google it.
     

Share This Page