iPhone 3GS low antenna signal

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Giuanniello, Oct 21, 2012.

  1. Giuanniello macrumors regular

    Giuanniello

    Joined:
    Oct 21, 2012
    Location:
    Capri - Italy
    #1
    My son's iPhone 3GS fell a while ago, I first changed the screen and it was ok, then found out that also the dock connector was gone and changed that too along with the whole case and vibration thing (which broke during the disassemble/reassemble process), all went smooth besides the fact that the signal shows very low where with other phones it is fully strong, I checked the antenna connector on the mainboard which seems not to be very tight, I made sure it is properly connected and applied a little piece of blue tape on it as to make sure it stays in place but, still, no result, the phone only works when in open air or where the signal is very very strong, what should I check to ensure proper functionality of the antenna?

    thank you

    Giovanni
     
  2. braxton34 macrumors member

    Joined:
    Mar 18, 2012
    #2
    Is the gold ground connector on the logic board intact?
    You also may have lost an inductor on the board close to where the antenna ribbon cable attaches.
     
  3. Giuanniello thread starter macrumors regular

    Giuanniello

    Joined:
    Oct 21, 2012
    Location:
    Capri - Italy
    #3
    The antenna connector, the gold round one, seems intact, in fact when I plug it in it stays sit in even though it is not really solid (I put a bit of blue tape on it to make sure it doesn't move), what about this inductor you wrote about, which one is it and how do I check if it is intact?

    By the way, the dock connector with the antenna cable is new, I replaced the old broken one.

    thank you
     

Share This Page