iPhone 3GS (new bootrom), jailbreakme only option?

Discussion in 'Jailbreaks and iOS Hacks' started by jaylay0707, Oct 24, 2010.

  1. jaylay0707 macrumors member

    Joined:
    Jun 29, 2008
    Location:
    the LBC
    #1
    I am purchasing a secondhand iPhone 3GS on OS 4.0 from a friend. He bought it in November of 2009, so I'm pretty sure it has the new bootrom. It's never been JB'd before. I've done some research, and it looks like since I don't have SHSH blobs for the old firmware it is impossible to JB with PwnageTool or other programs. Is jailbreakme the only option I have? My only concern is the security issue, but I heard that it plugs it upon installation.

    Also, as long as it's JB'd, unlocking won't be a problem, correct?

    I forgot to mention that I have no interest in upgrading the OS, or at least until I feel a little more comfortable playing with it :)

    Thanks in advance.
     
  2. nednarm macrumors 6502

    Joined:
    Apr 26, 2010
    Location:
    U.K
    #2
    Use the latest pwnage tool to jailbreak. It doesn't matter what bootrom the phones on it will be jailbreakable as of this moment in time.
    Also if you use pwnage tool you can opt to not upgrade the baseband thus you will be able to use ultrasn0w on 4.1

    Theres simply loads of threads on this, if you searched at all you would of found a whole bunch.
     
  3. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #3
    If you prefer to stay on 4 as you indicated then yes jailbreakme.com is the way to go. Remember to apply the Cydia patch to patch the PDF exploit after you JB successfully. If you want to upgrade to 4.1 at any time and you have a MAC then you can use pwnage tool to create a custom 4.1 which does not upgrade your baseband.
    The unlock is found in repo666 on cydia and it is called ultrasn0w.
     
  4. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #4
    jailbreaking and unlocking are two different things, if your friend already updated the phone to 4.1 then you are SOL for now to unlock it, if its in anything lower, then even w/out hashes you can create a custom fw in Pwange Tool for the fw 4.1 and that will preserve the BB from the older fw. For example, If you update a fw and then decide to downgrade, the BB will stay in the newer version and as of right now the BB that is in the fw of 4.1 cannot be unlocked...
     
  5. jaylay0707 thread starter macrumors member

    Joined:
    Jun 29, 2008
    Location:
    the LBC
    #5
    Thanks for the input all. It looks like I was looking at outdated material initially. So the new bootrom is not an issue anymore?

    Yes, thankfully the phone hasn't been updated to 4.1 otherwise I would have to wait until next month for a solution.
     
  6. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #6
    nope, not an issue anymore w/ the new version of PT you can preserve the old BB and have 4.1! The only requirement to use PT is a Mac & iTunes. :cool:
     

Share This Page