iPhone 3Gs - No backlight

Discussion in 'iPhone Tips, Help and Troubleshooting' started by FakedAce, May 6, 2011.

  1. FakedAce macrumors newbie

    Joined:
    May 6, 2011
    #1
    2 weeks ago, I found an iPhone 3Gs in the grass near a car park.
    It was all wet and I thought it was dead for sure. (Also, there wasn't a sim inserted in the phone!?)
    I put it on the heating for 2 days and then I put it in rice for 5 days.
    I never tried to turn it on because I knew it would be bad for the phone if it was wet.
    After that week I noticed that all the water inside the screen was gone and I plugged it in my computer.
    The screen turned on and the battery symbol appeared. It worked!
    I was soooo happy. But after 1 day of use, the phone wouldn't turn on again.
    I tried to fix it with iTunes but it said error code 1611. (Unknown)
    Searched for solutions but nothing worked for me, it stayed like that for a week.
    So I decided to open it and have a look.
    I separated all the opponents and I saw some corrosion on stuff like the battery and the motherboard.
    I used a toothbrush to clean it off and a degreaser, put it back together and it actually worked!! For 1 day...
    The backlight turned off and it turned on again the next day for about 3 hours.
    I tried to clean the whole motherboard and especially the area around the 6r8 coil.
    There was absolutely no corrosion there and the indicators on the motherboard are still white.
    I don't know what to do now and I already searched the whole internet but no solutions…
    If anyone has an idea of what I should do, please tell me.

    Thanks in advance!
     
  2. FakedAce thread starter macrumors newbie

    Joined:
    May 6, 2011

Share This Page