Iphone 3GS, no chance to restore?

Discussion in 'Jailbreaks and iOS Hacks' started by myiphonehatesme, Sep 7, 2011.

  1. myiphonehatesme macrumors newbie

    Joined:
    Sep 7, 2011
    #1
    Hello everyone,

    after I did 132 searches and tried everything, I will ask for help!

    I have an iPhone 3GS. I do not know the initial carrier. I had it unlocked and jailbroken but deleted everything by pressing the erase all content button.
    I do not know the last firmware, nor the baseband. I only know it was a tethered jailbreak before. I followed various instructions a few days ago to do a restore. But whatever I do (tried many firmwares, last one used was 4.3.3.), there is no chance to restore the iPhone without getting the message. The device is not eligible for this built. I know, you guys propose to delete the host files. I did that. Still no chance at all. :(

    Please help me, I love this phone (actually this particular one) and although I have an iPhone 4 to help me out, there is just no chance I would use it rather than this phone. Please give me some advice :confused::confused::confused:

    Thank you so much for any help! From what I have seen in this forum, the support is just incredible! :)
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Since you press that button, you have 2 options that you can do at the moment;

    1. Restore your phone to the latest firmware which is 4.3.5 with the condition that your phone does not have ipad baseband. it does, you can't restore to this office firmware. As for 4.3.3, Apple stops signing this firmware and that the reason you receive the error message.
    2. Restore it to 4.1 firmware, look for the thread in this forum and follow it.

    Either way, once you restore to one of this firmware, you can't unlock your phone with the baseband that come with these firmware. The only way you can unlock it is to install ipad baseband. Before you put this baseband on your phone, you should search for the consequences that come with it.
     
  3. myiphonehatesme thread starter macrumors newbie

    Joined:
    Sep 7, 2011
    #3
    I guess I'll try 4.3.5 once again then, since its easier to download through iTunes. I don't have to restore to some custom firmware? My internet connection reached its limit so it will need some time until I downloaded the firmware. I hope 4.3.5 works. I will report immediately, thanks a lot.
     
  4. myiphonehatesme thread starter macrumors newbie

    Joined:
    Sep 7, 2011
    #4
    update to 4.3.5 did not work, forgot the code, maybe 3015 ?
    update to 4.1 did not work either, code 20 in first attempt, after making sure its in DFU mode I tried again and encountered error code 1015 close to the end.

    :confused::confused::confused:
     
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #5
    Getting 1015 error is normal. At this stage, you need to use tiny umbrella to kick it out of recovery.

    Please make sure you read the thread about downgrade it to 4.1 and clearly understand all the steps and tools you need.
     
  6. myiphonehatesme thread starter macrumors newbie

    Joined:
    Sep 7, 2011
    #6
    God I am so confused. I tried it all. Tiny Umbrella only gives me the option to "fix recovery". When I click that there is a Greenpoinsing initialized screen for like 5 minutes and afterwards there comes something up and it says giving up...

    I then found that that is not what I need, however I can't press the exit recovery button since its not pressable. From various guides I got that I should not restore to 4.1. but to a 4.1 custom firmware. Is that correct?

    I can not use all the stuff like snow breeze or ireb r4 because I have a MAC.

    Right now I am just stuck with the 1015 error while trying to restore normally through iTunes to 4.1. WHAT SHALL I DO ? :(:(:(

    EDIT: Should I maybe try all this? http://www.redmondpie.com/jailbreak...1-on-iphone-4-ipad-ipod-touch-apple-tv-guide/
     
  7. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #7
    The 1015 error simply means that you are trying to update to a version of firmware that includes a baseband that is lower than the one already on the phone. The firmware will install normally but it will error as soon as the attempt to update the baseband is made.

    Your best option is to use pwnage tool and create a custom firmware for 4.1 and update to that. Since you have a 3GS you do not need SHSH for 4.1 since for some reason apple is still signing that firmware.

    You should used pwned DFU mode after creating the custom firmware and this is done using the count down timer provided in pwnage tool to put the phone in DFU mode. After you get to DFU close pwnage tool open Itunes and do option restore and select the custom firmware.
     
  8. myiphonehatesme thread starter macrumors newbie

    Joined:
    Sep 7, 2011
    #8
    Thanks! I will try that right now. It does not matter which iTunes version i use? Also not that I have the old 3GS with the old bootrom? Hope that works! thanks
     
  9. winglik macrumors newbie

    Joined:
    Sep 8, 2011
    #9
    If you are getting an error message when you try to restore to the latest firmware, most likely you have a patched Host file, open up the host file and remove "74.208.10.249 gs.apple.com" and restart itunes and try again. With a patched host file, you can restore previous firmwares(with SHSH backup), but not the latest firmware from apple.

    Also if you don't know the original carrier of your iphone, even after you restore it back, you won't able to activate it because you will need that carrier's sim to activate the phone after restoration. Your best way to get back your iphone is to restore to a custom firmware which already "activated", after that, you will need to unlock it, which is another long story.
     
  10. myiphonehatesme thread starter macrumors newbie

    Joined:
    Sep 7, 2011
    #10
    Resolved

    thank you so much nebo1ss.
    I restored to a custom firmware made by pwnagetool and could easily unlock with ultasnow.

    worked very smoothly!!!
    :):):):):)
     

Share This Page