iPhone 3GS Problem

Discussion in 'Jailbreaks and iOS Hacks' started by j11hnb, Dec 1, 2011.

  1. j11hnb macrumors newbie

    Joined:
    Dec 1, 2011
    #1
    Hello, first off I'm new here and after a bit help, I hope this should be in this part of the forum, but if not I apologise.

    I bought an iPhone off eBay for my girlfriend, and its kind of not working. The guy I bought it off said it was fine when he sent it, and won't accept a return.
    I have filed a complaint with PayPal but they won't do anything as the advert said sold as seen, which I stupidly didn't think nothing of at the time.

    Anyways, the screen is completely black, it never shows any sort of icons or anything, but when I connect it to iTunes it recognises the phone is in recovery mode. I try to restore it, and have even downloaded the .ipsw and manually chose that but still it won't let me restore. It comes up with error message 21 and 2001 etc etc.

    If I can get this sorted I won't be too fussed, as I got the phone a bit cheap, but nothing I seem to do works. I have used different computers, set up a guest account on my computer, tried holding the on/off button and home button at the same time etc but nothing works.

    The only time the phone ever seems to respond is when I try to restore it through iTunes it starts glowing but only black, no other colours, no other icons, no nothing. Does anyone have any sort of idea what it could be.

    Because of these errors I was getting (21) I got my mams old 3GS and put it in DFU mode and tried to restore it through itunes and it worked first time round. This make me think that it is the phone.

    I took it to the apple store and the lad there said that there was no water damage and he tried resetting it but couldnt help me any further. He also said that the phone was originally on a Canadian network or something, and must of been locked to it, so he can only presume that someone had tried to open it but they broken the phone when trying to do so. I know there is a fix for it, as he said they could fix the phone for £55 but ideally i dont want to pay that.

    I have also since tried resetting it through redsnow, and when I try to reset it, loads of white writing scrolls down the page, but then an error message comes up, i can only think that this is because i cant actually turn the phone off (which redsnow tells you to do) before i reset it.

    Ive also tried tinyumbrella but nothing works. Does anyone have any other ideas? Im using a mac osx 10.6.8 if that makes a difference.

    Will really appreciate any help that anyone gives me. I have posted this elsewhere, so if this explanation seems a bit disjointed i apologise, just i have copy and pasted to save some time :)

    John
     
  2. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    It is possible that the phone baseband was updated to the IPAD baseband inorder to unlock it. If this is so then you need to upgrade using custom firmware.

    You best option with a 3GS is to create a custom version of 4.1 either with Pwnage tool on a mac or snowbreeze on windows. After you create the custom firmware put the phone in pwned DFU mode and restore to the custom firmware.

    You could also try just downloading 4.1 and then putting the phone in DFU and do option restore on a MAC. The restore will fail with an error probably 1013 or 1015 but you should be able to use Tiny umbrella to then kick it out of recovery and you should be okay.
     
  3. j11hnb thread starter macrumors newbie

    Joined:
    Dec 1, 2011
    #3
    my only problem with this is i have a fully black screen, so how can i put it in pwnage dfu mode? i cant turn the device off when i run redsnow, or should redsnow still put it in the dfu mode?

    i downloaded a custom version of 4.1 but itunes will not allow me to install it saying the firmware is not compatible
     
  4. chargit macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #4
    ok you said fully black screen twice and that tells me the lcd is bad. but then you can see white words scrolling down the screen which says your lcd is good. so please be a little clearer on your description. can you in fact see white words?

    to be honest I would just pay the $55 and let them fix it
    cause I charge $60 for an lcd.
     
  5. j11hnb thread starter macrumors newbie

    Joined:
    Dec 1, 2011
    #5
    yes, there is an all black screen, but when i go to restore it via itunes i now get a white screen, but when i run tinyumbrella it gets some white writing on the screen and just doesnt do anything after that. think the last line says something about greenpoison. then, when i run redsnow and chose the jailbreak option some graphics come on the screen, also when i try another option i get a pineapple on the screen and thats it. ive got a new lcd and a new digitizer coming so hopefully i can get something sorted this way

    in the mean time if anyone has any other ideas let me know
     
  6. j11hnb thread starter macrumors newbie

    Joined:
    Dec 1, 2011
    #6
    i have taken the lcd and digitizer from my mams working iphone and put it in this phone, and still nothing works, so it hasnt got anything to do with the lcd or digitizer.

    any other ideas?
     
  7. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #7
    Your screen isn't broken! A broken screen won't display the stuff you said. You are making a mess.

    As second post states, your iphone may have ipad baseband. Google on how to do that.
     

Share This Page