iPhone 3GS Proximity sensor, Earpiece, and camera not working :(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jimmyx1, Jun 4, 2010.

  1. jimmyx1 macrumors newbie

    Joined:
    Jun 4, 2010
    #1
    Hey guys, I recently opened up my iPhone 3GS 32GB to change my battery, and them reassembled it. When I turned it on, everything was normal, but I noticed that the auto-brightness was not working. And when I tried to make a call, I couldn't hear any ringing, and the screen won't turn off by itself. After that, I started to panic and opened the Camera app, and no surprise: it wasn't working either; it stays at the startup screen. I tried it again with the old battery, and it didn't work either. I am sure that I screwed every screw and plugged in every ribbon! So, is there a way that I can fix this problem, or am I screwed?! Thank you in advance.

    Edit: I tightened the 3rd ribbon and now the earpiece is working (but not as clear), but the proximity and light sensor, and the camera still aren't working. I am confused!
     
  2. nismotony macrumors newbie

    Joined:
    Jun 20, 2011
    #2

    I have the same problems after I opened mine up. Did you ever find the solution??

    Thanks in advance
     
  3. ylerT macrumors regular

    ylerT

    Joined:
    Jun 10, 2011
    Location:
    Las Vegas
    #3
    First question might be silly but are you 100% positive you got a 3Gs battery and not a 3G battery?

    If so...I'd double check the #3 connection. It doesn't control the camera but it does control the speaker and proximity sensor. It's really easy to not get it in all the way and it's even easier to break so be careful.

    As far as the camera though, you're going to have to pull the logic board out of the phone to check. The camera connection is underneath the board. I'd pull the logic board out and just make sure everything is clean of dust/debris and fully connected.
     

Share This Page