iPhone 3gs screen dead after redsnow jailbreak

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sanjoyd4, Nov 28, 2011.

  1. sanjoyd4 macrumors newbie

    Joined:
    Nov 28, 2011
    #1
    Hi,I upgraded my iphone 3gs to 4.3.3 and jailbroken it using redsnow.It was working fine for like 15 mins.Then it went off.I tried pressing Power+Home button didnt work.So i restored it few more times but couldnt get it work.The display is completely black during the restore and i cant see neither the apple logo nor the progress bar during the restore proccess.Display never turns on.Itunes can detect it and i hear the sound when i connect it to usb.Voice control works also.I have the exact problem with my brand new iphone 4 also.Please help me figure it out.I am frustrated.

    Thanks
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    The LCD connection to the logic board might have lose. Did you try to open it up and see?
     
  3. M Quick macrumors 6502

    M Quick

    Joined:
    Nov 9, 2011
    Location:
    Stockholm, Sweden
    #3
    I guess you just got unlucky. Seems like a hardware problem! Open it up and have a looksi.
     
  4. sanjoyd4 thread starter macrumors newbie

    Joined:
    Nov 28, 2011
    #4
    i haven't opened it up yet.How can be hardware problem in both iphone? It just happened after jailbroken em'.
     
  5. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada

Share This Page