iPhone 3GS Screen somewhat not Responsive

Discussion in 'iPhone' started by puercaeli, Jul 31, 2009.

  1. puercaeli macrumors regular

    Joined:
    May 10, 2008
    #1
    Has anyone found iPhone 3GS somewhat less responsive?
    On quite regular basis, when I tap a button it won't register.

    It is not such an obvious and visible so I assume even if it is a wide spread problem many people would not notice(I kind of have hunch that this may be related to the oleophobic screen coating... may be sth along the line of uneven coating?)

    This saddens me very much cause one of the reason I bought
    iPhone was because of its superior touch screen technology.
     
  2. Unspoken Demise macrumors 68040

    Unspoken Demise

    Joined:
    Apr 16, 2009
    Location:
    >9,000
    #2
    Not to be condecending, I'm trying to help, but have you tried restarting the phone at least once every other day? It helps give it some time to reset. It usually helps with me.

    Your next step would be a restore, then from the iPhone's data as an existing phone.

    If that fails, try a restore as a new phone.

    If that fails, mapquest your nearest Apple Store.
     
  3. Eso macrumors 68000

    Eso

    Joined:
    Aug 14, 2008
    #3
    None of that will do anything.

    This is a common experience with the iPhone; it's not abnormal. Which apps do you experience it the most with?

    What is happening is that many apps will essentially show a picture (more on this) while it is still processing the application in the background. So when you try pressing one of the GUI buttons, the app hasn't actually loaded all the components yet and it may take a second or two to register your touch. This is usually the case with intensive, poorly coded, or initial versions of apps.

    When launching or closing apps, the screen is literally just a screenshot of the application. As the application loads it will become responsive. It's usually very quick (~1 second), but complex applications will take longer and some portions may be responsive before others. Try not to think of this behavior as a bad thing. Instead of displaying nothing while the application loads, it will at least show something.
     
  4. puercaeli thread starter macrumors regular

    Joined:
    May 10, 2008
    #4
    Thank you for the responses

    I restored it and it helped a bit but there still is some signs of less responsiveness.

    The reason I don't think it is performance related but specific to digitiser is because this seems to happen even when I am doing something not so performance intensive works(Eg. typing text on keyboard)

    It just seemed less response to iPod Touch or my friend's iPhone 3G....
    I think I will have test drive 3GS in Apple Store one and see if the problem is specific to mine.
     
  5. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #5
    Im kind of having the same issue. It becomes kinda unastable towards the bottom right sometimes.

    I dont know what it is exactly because i can press the keys but it wont type
    anything. Again its not all the time so i can tell how and when might happen so i can take it back to the store.

    I have restarted the phone, restore etc, to prevent from happenning. As im typing this it works great
     
  6. jingles8302 macrumors member

    Joined:
    Jun 16, 2009
    #6
    I have had the same issues on my 3GS. But sometimes it becomes so unresponsive i either put it to sleep and then wake it up and it is fine again. I took mine to the apple store and they said the connector to the touch screen to the pc board was loose. They fixed it and said it was fine. After i got it back about 10 minutes later it starts doing it again. Haven't had the chance to go back into apple yet as i live 3 hours away from my closest store. But when i do i am just gonna ask for a new device. What build week was yours? Mine is 926.
     
  7. puercaeli thread starter macrumors regular

    Joined:
    May 10, 2008
    #7
    9-25

    Mine is 9-25...I was first to buy in Apple Store Sydney:D

    Funny(or sad should I say) was my first unit had large scar on the chrome so had to get a new one. It is behaving fine except the fact that screen is somewhat less responsive. (also except the fact that there was a viyl piece in the earphone port...)

    I am trying to figure out a way to show this and I think best way to show this is by showing keyboard. However I am not so sure about how to show this at this stage since this is kind of 'subtle' issue. (I tried store unit and it seems to work ok... but difference is minor like less typos...) One would though QC have gone up since they have been making this for a while but this does not seem to be case... whilst I am not leaning towards iPhone is 'crap' it certainly lacks those details that makes user experience full and rich. I am kind of thinking QC issue is reason why Apple did not go with new design... they just can't keep QC up with such an enormous amount being produced.(probably no other company on this planet can cope with it either)

    I strongly believe this is due to the oleophobic coating screwing it up. May be uneven spread or may be it's interfering or may be it's not adhering to the surface very well(seeing that it can come off with the intense session of that 'fishing game...').

    TO SUM IT UP... 3GS LACKS THE FLUIDITY & GLIDE that 3G and TOUCH have...
     
  8. ChefJayPeek macrumors regular

    Joined:
    Jul 8, 2008
    Location:
    Suburban Texas
    #8
    No, to sum it up, YOUR iPhone has a problem, not all 3GS iPhones. Mine works fine.
     
  9. CKohkah macrumors 6502

    Joined:
    Jan 10, 2008
    #9
    do a DFU restore. It helped me and mine was doing the same thing...
     

Share This Page