iPhone 3Gs second new digitizer still not working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cassetout, Mar 8, 2012.

  1. cassetout macrumors newbie

    Joined:
    Mar 8, 2012
    #1
    Hi. I looked through several posts and saw that soem cheap digitizers don't always work.

    I have an old iPhone 3Gs that was working well until I changed the battery.
    I had changed the screen twice before. Due to lack of experience I applied force to the mother board and or bezel. It was still working well though until I changed the battery. After changing the battery I was getting into continuous loops of trying to install a firmware. I realised the battery was not working well, and decided to replace the case , and entire lower part excluding the mother board.

    It then worked fine, loaded a firmware ( iOS 5+5.1) no problem. Yet some funky things were happening with the lower rows of the keyboard unless I pushed down on the bottom left of the screen.


    I decided to then again replace the digitizer with a new one off Ebay.
    The new one still doesn't work, the lower side only works sometimes, but not the N and rarely the backspace.

    Trying to see why , I broke the LCD connector. Ordered a new one. The Speaker (connector 3?) clasp is missing yet the speaker and proximity still work.

    So my question is, is it possible that the soldered connection on the mother board is at fault or is it rather the digitizer or connection?

    I can feel the nº 2 connector snap when pushed down. Visually with a loupe there is no sign of breaks.

    Any advice would be greatly appreciated, and help avoid further floundering.
     
  2. normanbates macrumors regular

    Joined:
    Aug 24, 2011
    #2
    You have possibly broken a connector somewhere or the connector isn't pushed onto the board properly.

    That or the faulty battery has fried a component on the board somewhere.

    Out of curiosity did you get the digitisers from respected eBay sellers or just go for a cheap one and not bother looking at the seller's ratings?
     
  3. cassetout thread starter macrumors newbie

    Joined:
    Mar 8, 2012
    #3

    They in both cases sellers with very high sales and a solid background. I cannot say the authenticity of their parts. The second one has 3M tape and the piece looks fine. The battery was working with the old digitizer for more than two months. It was only when upgrading did it set into a recovery loop.

    As you said, it is probable that it is the connector on the board. Since I broke the LCD connector I have a new one coming and I will try to seat the Digitizer better. I looked with a 20X magnifier and there were some small pieces of glue on some contacts.
     

Share This Page