iPhone 3GS Shuts Off Occasionally When Idle

Discussion in 'iPhone' started by Sawtooth811, May 23, 2011.

  1. Sawtooth811, May 23, 2011
    Last edited: May 23, 2011

    Sawtooth811 macrumors 6502

    Sawtooth811

    Joined:
    Oct 18, 2007
    Location:
    Charleston, IL
    #1
    Hello. I'm having a minor problem (hopefully) with my iPhone 3GS. Please read the whole story if you can. :)

    The "Jailbroken" Part

    When I bought it from an eBay seller, it was jailbroken, but Cydia was the only app visible (which was the reason for it being on eBay). So I fixed it by restoring it to original factory settings, I then jailbroke it myself, and it was working perfectly fine.

    Then, whenever I let it idle WITHOUT it plugged in, and when came back to it, I pushed the home button, and it wouldn't turn back on. After that, I force-restarted it (Home + Sleep button for 10 seconds), the Apple logo shows up for about 5 seconds, then a white screen appears. I reboot it the same way again, but the second time, it stays in DFU mode (nothing but the screen being completely off). Whenever I plug it in and try to restore it, it says:

    - Your iPhone "iPhone" could not be restored. Error code (21)

    Luckily, since I'm good at taking apart/repairing Mac hardware, I disassembled the iPhone and unplugged the board from the battery for a few minutes, reassembled it, and it worked just fine again.


    The "Un-jailbreaking"

    Right after I got it to work again, I decided to un-jailbreak my iPhone by restoring it normally, and with success. It's 95% original now; However, sometimes when I let it idle like I did when it was jailbroken, the same thing happens, but now, this happen much less frequently when I let it idle, and on top of that, I reboot it, the iPhone boots normally like nothing happened.


    Let me give a few extra facts about the iPhone when this happens:
    • The iPhone does not do this while playing music
    • The iPhone was always charged at least 60%
    • It NEVER does this when plugged up to anything regardless of it being jailbroken
    • Error code 21 shows up in DFU restore mode regadless of jailbreaking, but it has the capablility of restoring normally
    • I can no longer jailbreak the iPhone due to the presence error code 21.

    Any help would be appreciated. Thanks, and I apologize for the long story. :apple:
     
  2. Sawtooth811 thread starter macrumors 6502

    Sawtooth811

    Joined:
    Oct 18, 2007
    Location:
    Charleston, IL
    #2
    The first time, I jailbroke it with Pwnagetool. I jailbroke it again last night with redsn0w this time, and it still has the same issue when it was jailbroken the first time, but I am able to get it working again without taking it apart. :confused:
     
  3. sud007, Oct 17, 2011
    Last edited: Oct 17, 2011

    sud007 macrumors newbie

    Joined:
    Sep 29, 2011
    #3

    thanks for u posted that, me too having same problem. IPhone 3gs on 4.2 , BB 6.15.00 got accidently updated to 4.3.5 got it stuck in recovery loop. Then after a downgrade to 4.3.3 with custom firmware worked.

    But the problem is same, it never boots on its own, always be in DFU mode!

    It had to be boot tethered, deactivated ,unlocked ,working fine..
    but this thing that it goes dark if left disconnected from lappy or left idle is sucking me!
    sometimes when it goes non responsively into DFU..had to open up too, separate circuit boards just like u did.

    but when I try to Restore it to original FW it gives errors...diffrernt each time


    which FW are u on?
    and which FW did u jailbreaked on earlier???
     

Share This Page