iPhone 3GS stuck in a white screen :(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by applemint101, Mar 21, 2012.

  1. applemint101 macrumors newbie

    Joined:
    Mar 21, 2012
    #1
    So, I had just upgraded it to iOS5.1 and then jailbroken it tethered. All is well until I left it on the table for around 4 minutes, picked it up, and realised it went back into DFU mode. After that I found out I cant boot it up at all, even with redsn0w. All it shows is a white screen, sometimes a black. I've tried googling and tried every possible solution, including holding both power and home button.
    The only one I haven't tried is letting the battery die.

    While I'm waiting for the battery to die, I hope any of you guys will be able to help me and give me a working solution.

    Oh, and I can't restore the phone. When I try to restore it with iTunes, it also gives me a white screen then iTunes will give an error code 28.

    Help? T_T

    Thanks in advance!
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Sounds like it has a hardware issue.
    Nothing that can be fixed with restores or software wise.
     
  3. applemint101 thread starter macrumors newbie

    Joined:
    Mar 21, 2012
    #3
    Oh my god, seriously? D:?!
    Does that mean the iphone's busted and all it's good for now is use it as a paper holder?

    EDIT: I'm still going to let the battery die. I at least have to try. D: Maybe miracles will happen and it'll work again?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    You can try but I dont think you will get anywhere.
    Try bringing it in to an iphone repair place if you have a local shop that repairs them. They will be able to find out what needs to be replaced and how much. Sometimes the repair is not worth it, or if its a small not too costly part it might be ok to pay to fix.
    Up to you.
     
  5. merkyone macrumors newbie

    Joined:
    Jul 22, 2010
    #5
    same exact problem here. i don't think it's hardware because phone was working fine on 3.1.2. i upgraded and jailbroke tethered and now i have exact same issue.
     

Share This Page