Iphone 3GS stuck in DFU Mode - Need Help

Discussion in 'Jailbreaks and iOS Hacks' started by joden007, Jul 24, 2011.

  1. joden007 macrumors newbie

    Joined:
    Jul 24, 2011
    #1
    Stuck in DFU Mode - Need Help

    Iphone 3GS
    Baseband - 6.15.00

    Tools used
    RedsnOw 0.9.6rc16
    sn0wbreeze 2.2.1
    TinyUmbrella 5.00.06

    Steps Taken So Far
    Was stuck with error 3194 but recovered it by using Tiny Umbrella
    Restored the device to 4.2.1(orginal firmaware) threw me error 1600
    Started Tiny umbrella
    Used redsn0w to enter DFU mode
    Used sn0wbreeze to create custom 4.2.1 firmware
    Itunes to restore using custom firmware
    Successfully restored but my iphone got stuck in DFU/Recovery Mode
    Again used RedSn0w for tethered reboot
    Iphone rebooted with pineapple logo and again flashed and went back to DFU mode

    Action Taken to recover from DFU mode

    Used greenp0ison but still same problem
    Used tinyumbrella fix recovery but no use
    Used iREB to fix recovery loop but still no use

    I have seen many blogs that tiny umbrella helps to fix this issue which they say by clicking on exit recovery will solve the issue. But in my case the 'Enter Recovery" and "Exit Recovery" buttons are Disabled.

    Anyone please help me resolve this issue. I have been researching on this for two weeks but still unsuccessful.
     
  2. labman, Jul 24, 2011
    Last edited: Jul 24, 2011

    labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #2
    1st of all you need to use Pwnage tools or Snowbreeze to cook a custom ispw to update because of the ipad baseband. you should be able to use those and reinstall the firmware and avoid the 1600 error tutorials are on iclarified.

    you should have never have used Redsn0w or Greenspos0in.

    http://www.redmondpie.com/how-to-pr....1-using-pwnagetool-4.2-sn0wbreeze-2.2-video/

    Also do you have blobs saved for 4.2.1 and did you use tiny umbrella during the install
     
  3. joden007 thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #3
    Hi labman.

    Initially i didnt use redsnow o greenpoison.... as u said used snowbreeze n tinumbrella....snowbreeze for custkm ipsw n tiny umbrella to avoid 1600 n 3194 error on 6.15 baseband....btw i have less knowledge on shsh blobs mean...can u please educate m on its usage ??
     
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #4
    ahh problem found if you don't know what they are you probably haven't saved any. you might be stuck until sn0wbreeze supports 5.0 since it is unlikely it will support 4.3.4

    http://www.idownloadblog.com/2011/03/13/what-is-an-shsh-blob/
     
  5. Tech Elementz macrumors 6502

    Joined:
    Jul 7, 2011
    #5
    16xx errors are usually fixed via Recboot or TinyUmbrella.

    3914 is an error while restoring to custom firmwares/SHSH blobs without pointing the update server to Saurik.
     
  6. joden007 thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #6
    Hi labman read what is shsh now....So i should wait until 5.0? Is there anyother way to fix this issue? Atleast a way to use my phone with orginal firmare(not jailbroken or unlocked) ? Restore process was successful with my 4.2.1 but the point to be considered is....it is not coming out of the recovery mode......
     
  7. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #7
    Do you know what firmware shsh tiny umbrella shows?
    Click on save shsh in TU and let me know.
    If you have 4.2.1 shsh
    Download sn0wbreeze.
    Cook a 4.2.1 with iPad baseband.
    Put phone in pwned dfu state.
    Shift + restore in iTunes .

    I guess u have done it once . Do it again.
     
  8. joden007 thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #8
    When i open tinyumbrella the option saveSHSH is disabled. I have attached the screen dump...advise me wat needs to be done
     

    Attached Files:

    • dump.jpg
      dump.jpg
      File size:
      57.7 KB
      Views:
      101
  9. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #9
    Attach your device :|
     
  10. joden007 thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #10
    Sttach my device ? My phone was already connected in USB port...apart from that i could not see any other option to attach my device in the GUI of tiny umbrella
     
  11. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #11
    Hmmm If it's connected why isnot it showing in the connected devices ?!?
     
  12. joden007 thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #12
    My device was connected...maybe as labman said i didnt save any shsh blobs before jailbreak restore....that ckuld be the reason why its not showin any devices
     
  13. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #13
    You don't want TSS server running when you are trying to save SHSH. Stop TSS server and connect your device again.
     
  14. mpalle macrumors newbie

    Joined:
    Aug 23, 2011
    #14
    Hi.
    I have for the last week or so tried everything to get my 3gs new bootram up and running. But everything i did led to either 150x or 3194.
    I didn't have any blobs saved anywhere so that was not an option.

    I pretty much had given up and put it on the shelf to wait for some wonder program to be released that could make it right, but saw that iH8sn0w.com had a program called iFaith.
    Downloaded it and tried to extract my blobs, first i got an error saying that the iOS installed (4.3.5) wasn't supportet. I put the phone in DFU mode and put iOS 4.1 on the device (resulting in itunes error 3194) and tried iFaith once more. Now it worked and 5 minutes later i had to choose a place to store my shsh file and then suddenly my iPhone booted normally.

    But now i was on 4.1 :( so i tried to let itunes upgrade it to the newest version and i was back it 3194 hell...

    Did the whole process again with same result.

    Not perfect, but better to have a unupgradeable iphone, than one that doesn't work at all :)

    Hope this helps somebody!

    Michael
     
  15. Tech Elementz macrumors 6502

    Joined:
    Jul 7, 2011
    #15
    Attempt to go into DFU mode again and press restore in iTunes. This should allow you to "Restore & Update".

    By the way, which SHSH blobs did you save with iFaith? Your post seemed a bit confusing.
     
  16. mpalle macrumors newbie

    Joined:
    Aug 23, 2011
    #16
    Hi
    I'll try that later on today.

    Thers a button called "Dump SHSH Blobs". Just hit that and waited :)

    Michael
     
  17. mpalle macrumors newbie

    Joined:
    Aug 23, 2011
  18. Ido1o macrumors newbie

    Joined:
    Dec 15, 2011
    #18
    Okay so the story goes like this:

    I bought an iPhone 3GS on ebay, and it came in the mail today. The title read "unlocked"

    I restored it on iTunes, which went horribly wrong and ended with the iPhone being stuck in a Recovery/DFU mode loop with no apple logo.
    I contacted the seller and he revealed that it was on iOS 4.1 with baseband 6.15.00 (Great.)

    So now I'm having no luck restoring it to a working state... any software version will work for me.

    It was origionally on AT&T but now I'll be using it on the Rogers network in Canada.

    Attempted:
    - Updating in iTunes to 4.3.5 (No Luck)
    - Restoring to an older version through iTunes with Tinyumbrella and redsn0w (no luck, 4.2.1, 4.1)

    I'm aware that the 6.15.00 baseband can't be rolled back, and I'm thinking the only way to get it to work would be to restore it to a custom iOS firmware
    that's been designed to work with 6.15.00.

    Any help will be much appreciated!
     

Share This Page