Iphone 3GS stuck in DFU mode!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by pureelite1, Apr 7, 2011.

  1. pureelite1, Apr 7, 2011
    Last edited: Apr 8, 2011

    pureelite1 macrumors member

    Joined:
    Nov 9, 2009
    #1
    It has been over a week now and phone wont function. Recently my gf's Iphone 3G was sluggish so she bought a 3GS from amazon. Little to her knowledge it was jail broken and unlocked. When she plugged it into itunes, itunes asked her that there was an update available for the Iphone 3GS version 4.3 i believe? However as the update was being installed a message popped up saying the update failed. She tried to restore it, but when she tried this error message 1015 popped up. She doesn't know what else to try. The phone is still in DFU mode and she had no idea the phone was jail broken and unlocked (pretty dumb i know). She tried something called red sn0w to reinstall the firmware 4.2 and ireb doesn't have a software for mac users (she has a mac). Any help will greatly be appreciated as she cannot afford a new phone. Thanks in advance :)
     
  2. jblair22 macrumors newbie

    Joined:
    Apr 8, 2011
    #2
    i had the same problem...

    but i have a fix! :)

    1)plug your phone into PC and load redsn0w_win_0.9.6b5 click to load iPhone1,2_4.1_8B117_Restore firmware then just click enter pawned DFU mode now. (nothing else)

    2)load itunes it will say your phone was found in recovery mode and needs to be restored so press "shift" and point to iPhone1,2_4.1_8B117_Restore firmware - it installs and after about 10mins you get 1015 error

    3) your phone will now be on the itunes USB cable screen

    4) load tinyumbrella-4.21.01 it will detect a iphone just press Exit Recovery

    5)Wait about 2minutes and the phone Should reboot and go back to the firmware apple loading screen - which after about 2mins does a strange apple install screen like firmware updgrade

    6) After about 2mins you should be back onto the apple stock activation screen - well that is what i see becuase my phone is not unlocked

    7) Go back to redsnow loading the 4.1 firmware Again NOT 4.1.2 and select jailbreak using the cydia and percent (and other options if you need except baseband)

    5) once the iphone is rebooted and it should be fixed

    if its fixed - you can keep as it is or do the same but swaping the to firmware 4.1.2



    hope it works for you!
     
  3. smalboy69 macrumors newbie

    Joined:
    May 27, 2011
    #3
    Same probleam

    Thanx bro its work !!!!
     

Share This Page