iPhone 3GS stuck in Recovery

Discussion in 'iPhone Tips, Help and Troubleshooting' started by WaelT, Jan 14, 2011.

  1. WaelT macrumors newbie

    WaelT

    Joined:
    Jan 14, 2011
    Location:
    Minnesota
    #1
    Greetings,
    I have an iPhone 3GS used to run ios 4.2.1 with BB 6.15, also JB using RedSn0w0.9.6b6, anyway i messed with cydia and since then the phone is stuck in recovery mode with a black screen ..
    I tried to downgrade to 4.1 using TinyUmbrella and Error 1015 "Since BB is different", TinyUmbrella should locate my iPhone and kick it out of recovery but it didn't see the phone at all, I tried iREB and it didn't work too..
    Then I downloaded 4.3 b1 and restored, also I couldn't kick it out of this mode .. Also I tried some custom ios and none worked :(

    Please provide me with any knowledge that can be useful

    Thanks a lot in advance :)
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    Your iPhone rebooted I'm guessing after you downloaded an app from Cydia? After that you should have open up Redsn0w on your computer, checked boot tethered, go through the steps and your 3GS will turn back on.

    Now, you need a custom 4.2.1 firmware with the iPad baseband to restore back.
     
  3. WaelT thread starter macrumors newbie

    WaelT

    Joined:
    Jan 14, 2011
    Location:
    Minnesota
    #3
    That sounds like a solution :D but ... Do you know any link that might be useful ??
    Thanks a lot :)
     
  4. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #4
  5. WaelT thread starter macrumors newbie

    WaelT

    Joined:
    Jan 14, 2011
    Location:
    Minnesota
    #5
    Thanks a lot pal :) you really saved me :D
    It worked, but I don't know if that is weird or not , but I had to JB more than two times and also I had to select "Just boot tethered" around 10 times to get it working ;)
    In the end it worked ... Thanks :cool:
     
  6. WaelT, Jan 15, 2011
    Last edited: Jan 15, 2011

    WaelT thread starter macrumors newbie

    WaelT

    Joined:
    Jan 14, 2011
    Location:
    Minnesota
    #6
    I have a new problem
    Now, when I press the sleep button at a random time, the iPhone goes off, just blank black.. And when I boot it "tethered" for the 1st time ... the screen goes blank white and I can hear the sound of the iPhone "I mean the sound when it finishs booting", I press the home button again and the screen goes crazy .. Colors are messed up badly and the screen positioning is totally wrongs. Anyway, when I re-do the "just boot tethered now" the iPhone works great agains !?!?!
    What seems to be the problem here ?!

    Thanks in advance
     
  7. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #7
    That, I have never head before, about the iPhone going insane. Restore the iPhone using the custom ipsw and jailbreak again.
     

Share This Page