iPhone 3GS stuck on "Connect to iTunes" logo

Discussion in 'iPhone Tips, Help and Troubleshooting' started by itsnevo, Oct 10, 2011.

  1. itsnevo macrumors member

    Feb 8, 2009
    I recently purchased a used iPhone 3GS with the old bootrom that I was planning on restoring and giving to one of my cousins and I've been having some major problems restoring the iPhone.

    It was jailbroken and unlocked when I purchased it and it was running the 4.2.1 06.15.00 Firmware which now makes me suspect that this may have been an iPhone that someone updated with the iPad firmware to unlock. The previous owner never informed me about how it was jailbroken and with what software.

    If it try to restore using the original Apple iPhone2_1_4.2.1_8C148a_Restore ipsw it says it's not compatible, if I try to update the firmware to the 4.3.5, it gets about 90% through the restore process before I get the 1015 error code. If I try restoring with the iPhone2_1_4.2.1_8C148a_Custom_Restore ipsw I get a message saying that the ipsw is not compatable. If I try using the iPhone1,2_4.2.1_8C148_Custom_Restore ipsw I end up getting the 1600 error message.

    I have tried Tinyumbrella and iREB to try to get past all the errors i get on iTunes (normally 1015 and 1600 error codes) and still can't get it to restore. When I try to use Tinyumbrella and iREB, it doesn't seem to do anything but put it in DFU mode. I still get all the error messages on iTunes.

    Unfortunately I've read that if you are running the iPod firmware and you try to restore to an official Apple ipsw, you end up bricking the iPhone and I've tried all the techniques I've found on the internet to try to unbrick it including going onto Redsn0w and putting it into the Pwned DFU mode to restore and still no luck.

    All I get is the "connect to iTunes" screen on the iPhone.

    Does anyone else know how I may be able to get this iPhone to restore? Back when the 4.2.1 firmware was new they said that for now on you could only upgrade the firmware using custom ipsw's, but since then is there anything new that may allow you to go back to original Apple firmwares?
  2. JunkyDog macrumors 6502

    Sep 17, 2011
    Have you tried snowbreeze? It allows you to use custom apple software.

    Hope it helps..
  3. itsnevo thread starter macrumors member

    Feb 8, 2009
    Problem Solved

    Unfortunately when I purchased the iPhone I was told that it was a 3GS and it turned out to only be a 3G iPhone so all the custom firmware IPSW's I've been trying to use have been for the wrong model iPhone.

    It's back up and running!

Share This Page