iPhone 3gs stuck on recovery mode! Error 21, 1600, and 1015

Discussion in 'Jailbreaks and iOS Hacks' started by NamiJana, Dec 20, 2010.

  1. NamiJana macrumors newbie

    Joined:
    Dec 20, 2010
    #1
    I have recently used redsnow to jailbreak my iPhone 3gs. I installed cydia and iPad baseband. Cydia was not working so I attempted to restore my iPhone using iTunes, but since i have iPad baseband I get error 1015.
    I have no clue what to do. I don't care about losing data or anything I just want my phone to work again. So please help!
    It's stuck on the connect to itunes screen and i have tried the following to fix it.

    -Attempted to re-jailbreak it, but after a few minutes with the pineapple logo on the screen, it goes back to the apple and then the connect to itunes screen.
    -Attempted to restore on itunes using custom firmware that i downloaded, but i get either Error 21 or 1600 depending on if its in recovery or DFU mode.
    -Even tried to use programs like tinyumbrella

    How do I fix this?
    Do I need to downgrade my iPhone to 4.1 or something? If so, how do i do that?
    I really need help. I have no clue what to do. Please and thank you in advance.
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    Once you get the iPad BB the only way you can restore/update/upgrade is using a custom IPSW created by pwnage tool, if you on a mac, go ahead download and create your custom IPSW and restore using that one. If you are on WIN, them you need to find someone you trust to make it for you.

    Once you got your custom IPSW, make sure you are on DFU mode, and restore using itunes, if your custom IPWS is a 4.1 IPSW you need your 4.1 SHSHs save, so check if you have them, if you don't you need to create a 4.2.1 custom IPSW. (base on error 21 and 1600 my guess is that you are trying to restore a 4.1 IPSW and your host file is pointing to Apple, it need to point to Cydia server, or you need a custom 4.2.1 IPSW and let Apple authenticate that)
     
  3. Yolenman macrumors newbie

    Joined:
    Dec 21, 2010
    #3
    Maturola - I had the same issue as above and your advise was on-point - thanks sooooo much. I dropped the 4.2.1 bundle into PWNage and cooked a custom restore file, shift restored and I'm a happy camper.... off to redsnow for jailbreak and then unlock. Again, thanks a bunch !!!
     
  4. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #4
    I'm glad it work out for you, I hope the OP also work his issue out. :D
     
  5. Ezdezat macrumors newbie

    Joined:
    Dec 13, 2010
    #5
    Hi i have iphone 4 with same problem. I was on 4.1 but can't remember the baseband, obviously can't check as i can't switch the phone on!

    This sounds like something i need to do, but your instructions are a bit vague for an amateur like me :eek:

    Anyone have a link to a step by step for dummies to do this?!

    Thanks
     
  6. mikelegacy macrumors 65816

    mikelegacy

    Joined:
    Dec 5, 2010
    Location:
    Pittsburgh, PA
    #6
    There are plenty of ways to aquire a custom IPSW for restoring with an iPad baseband. Although I did not make sure that this is a download, I believe this site has a link to a download:

    http://www.myappleware.com/iphone-jailbreak/s-3gs-4-2-1-with-6-15-bb-custom-ipsw.html

    When you download that and go to restore, you'll either need to hold shift or cntrl (not sure which one) when you press restore and you'll be able to select a custom firmware file. Select the new, custom one.
     
  7. cky.dude macrumors newbie

    Joined:
    Dec 26, 2010
    #7
    I downloaded like thousands IPSWs (custom, hactivated, original) and still no progress, not even in DFU mode... nothing works and I'm starting to feel very desperate... any advice? I'm on Windows 7 64bit, newest iTunes, iPhone 3gs w/ new bootrom
     
  8. sazafraz macrumors newbie

    Joined:
    Dec 21, 2010
    #8
    I had a similar problem as the OP and this worked for me.

    http://forums.macrumors.com/showthread.php?t=1064509

    Basically download the apple firmware and custom firmware (custom firmware link is posted there).

    Open redsn0w and select the apple firmware and go through the steps. For me, when I had to boot into DFU mode, redsn0w says to make sure that the iphone is off, however I was not able to turn mine off while it is plugged in the computer (just kept going to recovery mode) but I took the risk and did it while it was still on and followed the steps to putting it into DFU mode and it worked.

    I opened iTunes and it detected it and if you are on Windows, you will hold down SHIFT+Click Restore and then you can select the custom firmware ipsw from the computer. It will restore your iphone using the custom firmware and that worked perfectly and I was finally able to boot my iphone into regular mode and finish the rest of the process.
     
  9. cky.dude macrumors newbie

    Joined:
    Dec 26, 2010
    #9
    UPDATE: You just need to use redsn0w to get to pwned DFU and then use custom IPSW
     
  10. sasquachnw, Jan 1, 2011
    Last edited: Jan 1, 2011

    sasquachnw macrumors newbie

    Joined:
    Dec 23, 2010
    Location:
    Seattle WA.
    #10
    Having restore problems...using customer ISPW

    I believe I am having the same problem as those above this posting.
    I cannot get my 3G iOS 4.2.1 to restore after having problem...
    Device "was" jailbroken and unlocked and worked well. except I could not multitask
    I found instructions how to change the code (for multitasking) and then could not open device.
    So I decided to do a restore with the custom ISPW and start again.
    I have a custom ISPW, which I can access in DFU mode, by doing a shift "click" restore in Itunes.
    The process almost finishes and I get an error message either 1015 or 1601 that restore could not complete for unknown reason.
    Device goes back to "USB to Itunes" display
    I have also tried doing a restore from Redsn0w using the custom ISPW, again seems to go through the process, When redsn0w instructs to turn device off, I (believe) the device turn off and goes into DFU mode..I have noticed that if the device is not in DFU mode redsn0w does not continue.
    I get the "pineapple man" screen and then it goes into a screen with the "apple logo" in the display and the device does not change from this point.

    Can anybody help me

    Thank you
    sasquachnw
     
  11. bape47, Jan 1, 2011
    Last edited: Jan 1, 2011

    bape47 macrumors member

    bape47

    Joined:
    Jan 1, 2011
    Location:
    Vallejo California
    #11
    i got the 3GS same problem with u too.and i fix it with the FW custom of Sway.and i can jailbreak again but i cannot unlock it because when i update the cydia after that it doesnt work...so the next time i pass it no update and i go to add the soures repo666.ultrasnow.com install it and it say reboot device when the phone reboot i got the stuck at apple logo :( have some one have a problem like me and know to fix it please help..........thanks so much
     

Share This Page