Iphone 3GS unable to restore.

Discussion in 'Jailbreaks and iOS Hacks' started by xIKable, May 9, 2010.

  1. xIKable macrumors newbie

    Joined:
    May 9, 2010
    #1
    Recently, I used Spirit to Jailbreak my iPhone 3GS (Firmware 3.1.3) and due to a silly mistake I was forced to restore it. Unfortunatly I am recieving an error each time I attempt to restore. Or it just gets stuck on 'preparing iPhone for restore' the error code I got was 1604. I'm pretty new to this whole Jailbreaking thing but learn quickly from my mistakes.

    Any help would be much appreciated.

    'edit, error code is 1604 not 1602'
     
  2. xIKable thread starter macrumors newbie

    Joined:
    May 9, 2010
    #3
    Thankyou Mystikal but I have tried this aleready. It seems to not work with iPhone 3GS. Or am I going about it all wrong? I tried clicking the bottom button and selecting the ISPW like it asked and it failed.
     
  3. kbfr08 macrumors 6502

    Joined:
    Mar 16, 2007
    #4
    use redsn0w & 3.1.2 to get your iphone to the white screen, unplug it as soon as it turns white, close redsn0w. Then open itunes and flash your 3.1.3 firmware.
     

Share This Page