iPhone iPhone 3gs upgrade not working out so well

Discussion in 'Jailbreaks and iOS Hacks' started by mcsolas, Apr 26, 2014.

  1. mcsolas, Apr 26, 2014
    Last edited: Apr 26, 2014

    mcsolas macrumors regular

    Joined:
    Jan 4, 2013
    #1
    I was suggested to move into this forum from this thread.

    I was trying to upgrade my 3GS to ios 6 because I couldnt run some apps, like facebook. I figured that might help. I waited until I kind of had a few days free where I wouldn't need my phone *just in case* something like this happened.

    It all started when I did this step: Put your phone in DFU mode and let iTunes download the most up to date version of iOS(6.1.6) and restore your phone.

    Once it did, it said it couldn't find the SIM card. So I started looking into how to fix this. I came across this video and tried to follow along.

    I DL'ed the two files he recommended (redsn0w_mac_0.9.15b2) and (iPhone2,1_6.0_10A403_Restore.ipsw) and ran the app. When it asked "Is this a newer (fixed) model?" I initially chose no as it mentioned to look at the 4,5th digits of the SN. I later found a thread that said yes thats the week but the 3rd digit is the year. Either way, my SN starts with 88122, so I assuming thats 2011, week 22 or in other words, I have the 'newer (fixed) model'.

    Initially when I selected no, I couldnt get it to flash the baseband. I would get a: Missing Keys.plist data for this build error.

    I was able to get it to work by deselecting "Install iPad baseband". It went through the first time and seemed to work, but then when it was done, the device wouldn't boot up. I would hit the power buttons and nothing would happen. I googled around and also opened itunes and it is telling me the device is in recovery mode.

    I tried running redsn0w a few more times and was able to get it to reboot and got it back into DFU mode. From there I was also get it to flash the baseband once I selected 'yes' for the newer (fixed) model question. I also downloaded a newer version (redsn0w_mac_0.9.15b3) which I was using to try and make this work.

    However, still can't boot this thing up.

    I would be happy to just get either OS working at this point, 5 or 6. Any suggestions? I am feeling like I just got in way over my head.

    Edit: I was able to get itunes to restore it to a working state. however, when it boots up, it asks to be connected to iTunes. When it does, it still tells me "There is no SIM card installed in the iPhone you are attempting to activate." ... disconnect and insert a SIM. This phone on occasion I had to take the SIM card out and put it back to get it to recognize it. However, it was working fine when I started this process. I took it out 2x and it went from saying "Searching..." to "No Service" after the 2nd time...

    However, still stuck with a non-working phone at the moment.
     
  2. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #2
    Using WIFI, go to unlockit.co.nz on your iPhone3GS.
    When the tweak loads toggle your country and your cellular service (as requested).
    When you're done you should now have a working cellular connection and no longer the missing SIM popup.

    At least, it worked for me.
     
  3. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #3
    you're fortunate your phone is before the 28th week of 2011 or else you would've just destroyed your phone and turned it into an ipod (if not worse) and there wouldn't have been a way to fix it

    1. downgrade to iOS 4.1 (don't worry, it's still signed): http://appldnld.apple.com/iPhone4/061-7938.20100908.F3rCk/iPhone2,1_4.1_8B117_Restore.ipsw
    2. once on iOS 4.1, install the ipad baseband using redsn0w
    3. go to settings -> general -> about and check if the modem firmware (baseband) is 6.15.00
    3. after that, downgrade the baseband and do the same and check if the baseband is now 5.13.04
    4. if yes, download iOS 6.1.6: http://appldnld.apple.com/iOS6.1/091-3457.20140221.Btt3e/iPhone2,1_6.1.6_10B500_Restore.ipsw
    5. run redsn0w and click extras
    6. click custom ipsw and select the 6.1.6 ipsw you just downloaded and select yes when asked to perform the restore within redsn0w
    7. follow the steps and such and afterwards you should be on 6.1.6
    8. go and check your baseband version and confirm it is 5.13.04
    9. after that, run redsn0w again and click extras
    10. click select ipsw and choose the 6.0 ipsw you downloaded previously
    11. click back and select jailbreak and then follow the instructions and checkbox ONLY install cydia and then continue
    12. afterwards you'll have a jailbroken device with cydia installed
    13. open cydia and let it do its thing and then it'll close
    14. reopen cydia and search for the package "p0sixspwn" and install that
    15. it either tells you to reboot or respring, tap it and open cydia again after the reboot
    16. search for the package "ultrasn0w" and install that and respring/reboot and you should now be able to get signal with your SIM card (i assume t-mobile if you're in the USA?)
    17. afterwards, you should have an untethered jailbreak with software unlock on iOS 6.1.6


    or a simpler way would be to call up at&t and ask them to unlock the device. if they grant your request, just do a clean restore in itunes and your SIM card will work out of the box without having you to do any sort of jailbreak

    ----------

    Looking at the info he gave, it seems the phone is carrier locked
     
  4. mcsolas, Apr 26, 2014
    Last edited: Apr 26, 2014

    mcsolas thread starter macrumors regular

    Joined:
    Jan 4, 2013
    #4
    Wow!! thanks for taking the time to help me out here... I was starting to wonder if I had already done so at one point. :eek: Guess I got pretty lucky I should have done more research on the subject or left it as it was... I just wanted to try and use a few apps that wouldn't load on the older v.5 ios.

    I am going to very carefully try and follow your instructions and try and recoup this mess I am in.

    ///

    Yes, I think it was carrier locked. I bought it used so I do not know the whole story behind it but I would assume so. I also am in Costa Rica, I think you have to unlock them to use them here either way.

    /// edit

    Somehow when I came back to it later after trying the itunes restore.. I just gave it one more shot at booting up and it seemed to activate from itunes somehow through wireless and it worked. I had tried several times and it said it failed, to try again later... then later it actually worked.

    I was kind of surprised. I was then able to follow the instructions here to finish the process out: http://www.iphonehacks.com/2014/03/jailbreak-ios-6-1-6-redsn0w-p0sixspwn.html

    I went back and booted it up and through redsn0w was able to install cydia, then boot tethered, then update cydia, then find the p0sixspwn package and install it. I was then able to reboot the device and cydia remained.. so I assume that means the process worked.

    However, it still says 'no service' at the top. Bummer.. but I think now all I have to do is go to the carrier and see if they can help me from here.

    We will see.. what a mess, I should have just left it as is but .. I did learn quite a lot about how the process works today! Still not out of the woods yet but .. I think I am at least closer to a resolution. its nice to see the device boot back up.
     
  5. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    go to settings -> general -> about
    what is your modem firmware version?
     
  6. mcsolas thread starter macrumors regular

    Joined:
    Jan 4, 2013
    #6
    Modem Firmware: 06.15.00
    Version: 6.1.6 (10B500)
    Carrier: Not Available
    ICCID: No Sim

    Not sure if this means its not seeing the SIM card. I did have a few issues with that in the past. I am trying to re-seat the card and rebooted the device a few times but with no luck... when I started the process the sim was working fine, but I did remove it during the process so this could be it? Not sure.. a visit to the carrier tomorrow may hopefully get me back in order.
     
  7. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #7
    use redsn0w to downgrade your baseband
    if done successfully, it should be on 5.13.04

    after that, install ultrasn0w from cydia and you should be able to get signal again
     
  8. mcsolas thread starter macrumors regular

    Joined:
    Jan 4, 2013
    #8
    I gave it a try to downgrade to ios 4. Starting with step 1.. I wasn't sure exactly how to downgrade (im looking around now online for some walkthroughs on this specific step).

    What I did - I selected the IPSW file just like I did for the upgrade first, then clicked jailbreak, then checked to install cydia but left the install baseband option unchecked since it looked like you wanted me to do the ios 4 install first.... Maybe this wasn't the right menu command to use.

    It got started with the b/w screen and the text output, but it pretty quickly got to a step where it said AppleBasebank: Could not find mux function and froze. The device booted back up fine and is still on ios 6.

    I am wondering about getting it going again just on ios 5... since that what was working before. I am looking around for tutorials on that process now.
     
  9. darricksailo, Apr 27, 2014
    Last edited: Apr 27, 2014

    darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #9
    okay, so after you download the 4.1 ipsw
    open itunes
    hold shift and then click restore
    choose the 4.1 ipsw you just downloaded
    and it will restore without any problems because that version is still being signed

    since you're on the 6.15.00 baseband, you will probably enter recovery mode (usb with the itunes logo on the screen) after the restore is done
    open tinyumbrella and click exit recovery, it should kick you out of recovery mode and onto the homescreen

    now, proceed to downgrade the ipad baseband, you do not need to upgrade to the ipad baseband first since you're already on that version


    you need valid and complete SHSH blobs if you want to go to iOS 5, in tinyumbrella, it will give you your device's ECID (Dec), if you PM me that, I can check if you have valid SHSH blobs for iOS 5

    edit: alright, so i did some research and found out redsn0w doesn't support making iOS 6.x custom firmware

    1. in that case, just download the iOS 6.1.6 ipsw: http://appldnld.apple.com/iOS6.1/091-3457.20140221.Btt3e/iPhone2,1_6.1.6_10B500_Restore.ipsw
    2. open itunes, plug in your iphone, hold shift and then click restore
    3. select the 6.1.6 ipsw and it'll complete the restore process
    4. open redsn0w, click extras, click select ipsw
    5. choose the iOS 6.0 ipsw and select no since you have the older version
    6. go back to the main menu and select jailbreak
    7. it'll proceed to jailbreak and hacktivate your device
    8. after it is jailbroken on 6.1.6, install p0sixspwn from cydia to untether it and reboot your device
    9. downgrade the ipad baseband using redsn0w
    10. when your modem firmware (baseband) is shown to be 5.13.04 in your settings, install ultrasn0w from cydia and your SIM card should work

    sorry for the confusion, was not aware redsn0w couldn't create custom ipsw
     
  10. mcsolas, Apr 27, 2014
    Last edited: Apr 27, 2014

    mcsolas thread starter macrumors regular

    Joined:
    Jan 4, 2013
    #10
    Ok, I figured out how to get this to work, Im on a mac, when clicking it with shift didn't work, I looked around (here) and found a similar tute relating to downgrading to ios 5... but I figured out here that its option-click that lets you select the file.

    However, I ran into this error: The iPhone "iPhon" could not be restored. An unknown error occurred (20).

    tinyumbrella? heading back to google to figure this part out as its stuck on this screen right now...

    I will PM you.. I have this info, I saw it come up at some point yesterday and made note of it.

    Yeah I ran into this at some point..

    Regarding step 9, how would I do that after 6.1.6 is installed?

    edit: I got it out of recovery mode somehow using the "recovery fix" button on redsn0w. 6.1.6 is still installed / still on the new bootroom. I already had untethered it using p0sixspwn. I added the repository this morning and installed ultrasn0w and the fixer for 6.1 which a tute I found said I would need as well to get the signal back. No luck there but thats where I am at right now.. somewhere floating between steps 8-10. Looks like if I can downgrade the baseband I may be in business... but I probably should remove the ultrasn0w packages 1st?

    Also, still unsure how to go about the downgrade (step 9). I am thinking I would select the ios 4 ipsw file you had me download and just have it install the baseband option in the jailbreak menu?
     

Share This Page