iPhone 3GS was unlocked, now restored and don't work

Discussion in 'Jailbreaks and iOS Hacks' started by Rreila, May 4, 2012.

  1. Rreila macrumors newbie

    Joined:
    May 4, 2012
    #1
    Hello

    So I have an iPhone 3GS that was unlocked and I used tmobile sim card. My phone had some issues, and so I restored the phone using iTunes back to original factory. Now I can't get pass the setup part and unable to use my phone. I have AT&T now. How to fix this?*

    Any help would be appreciated thank you!
     
  2. aziatiklover macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #2
    U got to be specific cuz what kinda unlocked did u have? Factory unlocked? Ultrasnow unlocked? Ipad baseband unlocked? Ect.....
     
  3. Rreila thread starter macrumors newbie

    Joined:
    May 4, 2012
    #3
    Uh that I don't know... It was unlocked by my friends dad...
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    We cannot guess, sorry.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    It was jb and software unlocked most likely.
    You never supposed to restore to official firmware.
    You will always lose the unlock.
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    Sounds like you are stuck on the activation screen, just jailbreak the phone with redsn0w.

    During the jailbreak you can check activated and it should bypass the activation screen.

    From there you can check what firmware/Baseband you have and take it from there
     

Share This Page