iPhone 3GS will go to Apple Logo, then shut off unexpectedly

Discussion in 'iPhone Tips, Help and Troubleshooting' started by wrathofhawk, Apr 8, 2010.

  1. wrathofhawk macrumors newbie

    wrathofhawk

    Joined:
    Aug 13, 2009
    #1
    I have an iPhone 3GS jailbroken on 3.1 firmware. A couple weeks ago I was on the Facebook app and my phone froze, so I did the home button + power button force reset, and since then whenever I turn my phone on it will go to the Apple Logo for about 30 seconds, then just shut off. I know I can restore, but I haven't backed up my phone since last October, and there's a ton of photos and videos among other things I don't want to lose. I have heard of iRecovery but my phone must be in restore mode in order for that program to work. Hopefully there is someone that has been through the same thing and has managed a work-around, I am open to any suggestions as long as it doesn't involve restoring...

    EDIT: If I have to restore it I will, I'm just trying to find out if there's ANY other way of fixing it.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Try irecovery.
    It should take it out of the bootloop and hopefully fire up again.
     
  3. wrathofhawk thread starter macrumors newbie

    wrathofhawk

    Joined:
    Aug 13, 2009
    #3
    From what I read, iRecovery is compatible with every model but the 3GS. Can it work on an 3GS?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.

Share This Page