iPhone 3GS Won't get Earthlink Email Through Cellular

Discussion in 'iPhone Tips, Help and Troubleshooting' started by woodyrr, Apr 18, 2010.

  1. woodyrr macrumors member

    Joined:
    Aug 19, 2008
    #1
    After working flawlessly since the day I bought it last year, two days ago my iPhone tried to get my mail from Earthlink. After grinding for a long time, I got a dialog stating that it was unable to retrieve the mail because the server had stopped responding. I tried using my Yahoo mail account and it sent and received correctly. I also found that while I was able to surf the web, I could not access any of the earthlink.net web pages as the server stopped responding in this case too. I was in Dallas, TX when his happened and I have returned home to Oklahoma City and still have the same problem. This problem is restricted to using the cellular network. When I got to the house and was within range of my wifi, all of the emails from the past couple of days came in just fine and I am able to connect with earthlink.net.

    Can someone tell me if this sounds like an iPhone issue, an AT&T problem, or something up at Earthlink so I know where to start looking.
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #2
    Hrm, very weird. I just tried turning off wireless and connecting to earthlink.net via Safari and it didn't work.

    I exited out of Safari and then went back in and tried again, it seemed to work.

    So, I went and checked out their DNS, and one of their servers was not working right, thus 50% of all requests would fail.

    http://www.squish.net/dnscheck/

    I assume it is/was an earthlink issue.
     
  3. woodyrr thread starter macrumors member

    Joined:
    Aug 19, 2008
    #3
    Thanks.

    I must be the one whose buttered side of the bread always lands face down on the floor.

    My iPhone tries to get email every fifteen minutes and it was trying hard since I turned it on Friday morning. All day Friday and all day Saturday it never got connected to the working server. And with two or three attempts just now I still can't get in. I guess I'll just rely on wifi until they get it fixed. I'll bet a call to Earthlink tech support would be an exercise in futility and frustration.
     
  4. bks691 macrumors regular

    Joined:
    Apr 18, 2009
    #4
    Yes, very strange. I didn't notice it until you pointed it out. I can't access my start page or webmail. Yeah, the last time I called Earthlink for a problem, I spent two hours talking to some guy in India that told me I must replace my new Mac because it was out dated??? WTF :D
     
  5. drkilmer macrumors newbie

    Joined:
    Dec 26, 2008
    #5
    I've been having exactly the same issue as Woodyrr. Can't send/receive email, can't connect to earthlink.net over 3g, but can connect just fine via wifi. Tried contacting earthlink last night with predictable results ... they said it must be at att problem. Obviously this isn't the case, since it seems to only be earthlink that is effected. It's actually been slightly better this morning but still not great. Very frustrating.
     
  6. Saralea macrumors newbie

    Joined:
    Apr 19, 2010
    #6
    I'm currently having this same problem. This is the only place I've found it mentioned. Iphone can get email only when on a wifi network, not through AT & T. I can't connect to the webmail site without wifi either. Did anyone figure out how to fix it? Earthlink tech. support is supposed to call me back....I'm not holding my breath. This issue started yesterday and is still happening today.
     
  7. RuthS macrumors newbie

    Joined:
    Apr 19, 2010
    #7
    Earthlink problems

    I'm had the same problem for the last couple days--lots of earthlink downtime on my iPhone (although sometimes mail does get through). If anyone gets a fix, please post here (and I'll do the same). Thanks.
     
  8. RuthS macrumors newbie

    Joined:
    Apr 19, 2010
    #8
    Earthlink fix

    After some experimentation, it became clear that the problem was neither AT&T or Earthlink. So I deleted the Earthlink accounts from my iPhone and reentered them. Problem solved. Something must have gotten corrupted during a sync at some point.
     
  9. woodyrr thread starter macrumors member

    Joined:
    Aug 19, 2008
    #9
    When this first happened, I tried to add an earthlink account and couldn't contact the server to establish it.

    The good news is that as of now, after four days with absolutely no access through cellular, I'm back on line with earthlink email and earthlink.net without doing anything.

    I am going to leave the wifi capability off and see what happens in the morning. Perhaps the problem has been solved.
     
  10. Saralea macrumors newbie

    Joined:
    Apr 19, 2010
    #10
    My iPhone is again receiving earthlink email after not working for 2 days. I did nothing, it just started working again.
     

Share This Page